通达信行情牛熊开始结束主图指标 源码

源码_通达信_通达信主筹估算三买点副图指标公式源码

通达信行情牛熊开始结束主图指标 源码 :

XA1:=IF(DATE<99999999,1,DRAWNULL);

牛熊线:DMA(MA(CLOSE+REF(CLOSE,5)*XA1/CLOSE*0.098,90),VOL),LINETHICK1,CIRCLEDOT,COLORYELLOW;

小牛:=CROSS(C,牛熊线);

DRAWTEXT(小牛,L,'走强区')*XA1,COLORRED,LINETHICK4;

DRAWTEXT(ISLASTBAR,牛熊线,'牛熊线'),COLORYELLOW;

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;

MXD:=IF((DATETODAY(DATE))<99999999,1,DRAWNULL);

操盘线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))*MXD/210,NODRAW;

安全线:MA(操盘线,11)*XA1*MXD,COLORGRAY,LINESTICK,LINETHICK1;

MA20:MA(C,20)*MXD,NODRAW;

趋势线:MA(C,6)*XA1 COLORGREEN, LINETHICK2;

STICKLINE(趋势线>=MA20,CLOSE,OPEN,3,0)*MXD,COLOR0000FF;

STICKLINE(趋势线>=MA20,CLOSE,OPEN,0.5,0)*MXD,COLORCC66FF;

STICKLINE(MA20>趋势线,CLOSE,OPEN,3,0)*MXD,COLORFF9900;

STICKLINE(MA20>趋势线,CLOSE,OPEN,0.5,0)*MXD,COLORFFCC00;

大牛:=CROSS(趋势线,MA20)*XA1;

死牛:=CROSS(MA20,趋势线)*XA1;

DRAWTEXT(大牛,L,'行情开始')*XA1,COLORYELLOW,LINETHICK4;

DRAWTEXT(死牛,H,'行情结束')*XA1,COLORWHITE  ,LINETHICK4;

STICKLINE(CROSS(趋势线,MA20)*MXD,OPEN,CLOSE,2,0),COLOR00FFFF  ;

STICKLINE(CROSS(MA20,趋势线)*MXD,OPEN,CLOSE,2,0),COLOR00DD00;

VAR2:=O>MA(C,安全线)*MXD AND C<MA(C,安全线)*XA1;

STICKLINE(CROSS(安全线,C),OPEN,CLOSE,2,0)*MXD,COLORFF0000;

AMA3:IF(趋势线/REF(趋势线,安全线)>0.997,趋势线,DRAWNULL)*XA1,COLORBLUE,LINETHICK3;

AMA4:IF(趋势线/REF(趋势线,安全线)>1.001,趋势线,DRAWNULL)*XA1,COLORRED,LINETHICK3;

WH1:=IF(L=LLV(L,9),L,0)*MXD;

WH2:=CONST(BARSLAST(WH1!=0))*MXD;

WH3:=CONST(IF(WH2=0,H,REF(H,WH2)))*MXD;

WH4:=CONST(REF(BARSLAST(H>WH3),WH2+1)+WH2+1)*MXD;

WH5:=CONST(IF(WH4=0,H,REF(H,WH4)))*MXD;

WH6:=CONST(REF(BARSLAST(H>WH5),WH4+1)+WH4+1)*MXD;

WH7:IF(CURRBARSCOUNT<=WH2+10,CONST(IF(WH6=0,H,REF(H,WH6))),DRAWNULL)*MXD,COLORYELLOW,DOTLINE;

DRAWTEXT(ISLASTBAR,WH7,'进场线')*XA1,COLORYELLOW;

DP:=IF(C=INDEXC,0,1)*MXD;

GJ:=AMOUNT/V/100;

明日阻力:=L+(GJ-L)+(C-L)*MXD;

明日支撑:=L+(C-GJ)*MXD;

今日阻力:REF(明日阻力 , 1)NODRAW;

今日支撑:REF(明日支撑 , 1)NODRAW;

{止盈价是股价盘中破掉了三十分钟不再站上来,

源码_指标_通达信追涨类的精品指标――鼎牛涨停狙击 副图/选股预警 源码

立即止盈出局};

DRAWTEXT_FIX(1,0,0.05,0,'金【趋势线上穿安全线是鱼身行情出现的信号】')*XA1,COLORYELLOW;

DRAWTEXT_FIX(1,0,0.1,0,'木【趋势线下穿安全线是行情完全结束的信号】')*XA1,COLORGREEN;

DRAWTEXT_FIX(1,0,0.15,0,'水【K线变蓝色下穿安全线是行情提前结束的信号】')*XA1,COLORMAGENTA;

DRAWTEXT_FIX(1,0,0.2,0,'火【安全线上的红色K线就持股,灰蓝色K线就持币】')*XA1,COLORRED;

DRAWTEXT_FIX(1,0,0.25,0,'土【K线上穿牛熊线为强势区,跟着行情死盯一只股买】')*XA1,COLORCYAN;

通达信_通达信双针探底优化版 公式评测胜率高达92% 底部选股公式 无未来 无密码


原文链接:https://www.zhibiaow.com/124159.html,转载请注明出处!感谢您 的配合。