通达信今买明卖超级短线金钻指标公式源码

通达信今买明卖超级短线金钻指标公式编写说明:

XA_1赋值:收阴线
XA_2赋值:从前2日到前1日持续XA_1
XA_3赋值:收阴线
XA_4赋值:3日前的开盘价/收盘价>1.09
XA_5赋值:成交量(手)>1日前的成交量(手)*1.2
XA_6赋值:成交量(手)<2日前的成交量(手)*1.4
XA_7赋值:最低价<2日前的最低价*1
XA_8赋值:开盘价和收盘价的较大值/开盘价和收盘价的较小值>1.035
XA_9赋值:开盘价/收盘价>1.035
XA_10赋值:统计6日中满足XA_8的天数>=1
XA_11赋值:最高价<4日前的最低价*0.998
XA_12赋值:收盘价/最低价<1.02
XA_13赋值:1日前的收盘价/收盘价>1.001
XA_14赋值:6日前的开盘价/收盘价>=1.02
XA_15赋值:开盘价<1日前的最低价*1.02
XA_16赋值:如果模糊匹配品种名称ORNAMELIKE(2),返回0,否则返回1
XA_17赋值:1日前的最高价<2日前的收盘价的5日简单移动平均*1.01
XA_18赋值:1日前的收盘价的5日简单移动平均/1日前的最高价>=1.001
XA_19赋值:收盘价的16日指数移动平均/开盘价>1.025
XA_20赋值:1日前的收盘价-最低价<1日前的开盘价-收盘价
XA_21赋值:(最高价+最低价+收盘价)/3
XA_22赋值:(XA_21-XA_21的14日简单移动平均)/(0.015*XA_21的14日平均绝对偏差)
XA_23赋值:1日前的XA_22-XA_22<20
XA_24赋值:3日前的收阴线 AND 2日前的最高价<2日前的收盘价的5日简单移动平均
XA_25赋值:开盘价/收盘价>1.0995
XA_26赋值:统计7日中满足XA_25的天数=0
XA_27赋值:19日内最高价的最高值/20日内最低价的最低值>=1.2
XA_28赋值:XA_2ANDXA_3ANDXA_4ANDXA_5ANDXA_6ANDXA_7ANDXA_10ANDXA_11ANDXA_12ANDXA_13ANDXA_14ANDXA_15ANDXA_16ANDXA_18ANDXA_19ANDXA_26ANDXA_27的2日过滤
XA_29赋值:最高价<收盘价的7日简单移动平均
XA_30赋值:从前4日到前2日持续XA_29
XA_31赋值:1日前的收盘价>1日前的收盘价的3日简单移动平均
XA_32赋值:最低价>2日前的最低价
XA_33赋值:成交量(手)>1日前的成交量(手)*0.6 AND 成交量(手)<1日前的成交量(手)*1.3
XA_34赋值:1日前的最低价>2日前的最低价*0.985
XA_35赋值:成交量(手)<=成交量(手)的60日简单移动平均
XA_36赋值:1日前的收盘价/1日前的收盘价的5日简单移动平均<1.05
XA_37赋值:最高价<5日前的最高价
XA_38赋值:开盘价和收盘价的较大值/开盘价和收盘价的较小值<1.06
XA_39赋值:收盘价的20日简单移动平均/收盘价>1.09
XA_40赋值:收盘价的60日指数移动平均/收盘价>1.08 AND 收盘价的60日指数移动平均/收盘价<1.25
XA_41赋值:5日前的收盘价/收盘价>1.025
XA_42赋值:收盘价/最低价<1.035
XA_43赋值:5日前的成交量(手)>成交量(手)*0.8
XA_44赋值:4日前的成交量(手)<成交量(手)*2
XA_45赋值:1日前的开盘价<=2日前的收盘价*1.02
XA_46赋值:开盘价<1日前的收盘价*1.002
XA_47赋值:开盘价和收盘价的较大值/开盘价和收盘价的较小值<1.04
XA_48赋值:收盘价-10日前的收盘价
XA_49赋值:XA_48的6日指数移动平均
XA_50赋值:XA_49>1日前的XA_48*0.97
XA_51赋值:XA_30ANDXA_31ANDXA_33ANDXA_34ANDXA_38ANDXA_39ANDXA_41ANDXA_42ANDXA_43ANDXA_44ANDXA_40ANDXA_45ANDXA_46ANDXA_50的2日过滤
输出XG:XA_28 OR XA_51,画红色,线宽为2

通达信今买明卖超级短线金钻指标公式源码登录后下复制:

XA_1:=OPEN>CLOSE;
XA_2:=LAST(XA_1,2,1);
XA_3:=OPEN>CLOSE;
XA_4:=REF(OPEN,3)/CLOSE>1.09;
XA_5:=VOL>REF(VOL,1)*1.2;
XA_6:=VOL<REF(VOL,2)*1.4;
XA_7:=LOW<REF(LOW,2)*1;
XA_8:=MAX(OPEN,CLOSE)/MIN(OPEN,CLOSE)>1.035;
XA_9:=OPEN/CLOSE>1.035;
XA_10:=COUNT(XA_8,6)>=1;
XA_11:=HIGH<REF(LOW,4)*0.998;
XA_12:=CLOSE/LOW<1.02;
XA_13:=REF(CLOSE,1)/CLOSE>1.001;
XA_14:=REF(OPEN,6)/CLOSE>=1.02;
XA_15:=OPEN<REF(LOW,1)*1.02;
XA_16:=IF(NAMELIKE(1) OR NAMELIKE(2),0,1);
XA_17:=REF(HIGH,1)<REF(MA(CLOSE,5),2)*1.01;
XA_18:=REF(MA(CLOSE,5),1)/REF(HIGH,1)>=1.001;
XA_19:=EMA(CLOSE,16)/OPEN>1.025;
XA_20:=REF(CLOSE-LOW,1)<REF(OPEN-CLOSE,1);
XA_21:=(HIGH+LOW+CLOSE)/3;
XA_22:=(XA_21-MA(XA_21,14))/(0.015*AVEDEV(XA_21,14));
XA_23:=REF(XA_22,1)-XA_22<20;
XA_24:=REF(OPEN>CLOSE,3) AND REF(HIGH,2)<REF(MA(CLOSE,5),2);
XA_25:=OPEN/CLOSE>1.0995;
XA_26:=COUNT(XA_25,7)=0;
XA_27:=HHV(HIGH,19)/LLV(LOW,20)>=1.2;
XA_28:=FILTER(XA_2 AND XA_3 AND XA_4 AND XA_5 AND XA_6 AND XA_7 AND XA_10 AND XA_11 AND XA_12 AND XA_13 AND XA_14 AND XA_15 AND XA_16 AND XA_18 AND XA_19 AND XA_26 AND XA_27,2);
XA_29:=HIGH<MA(CLOSE,7);
XA_30:=LAST(XA_29,4,2);
XA_31:=REF(CLOSE,1)>REF(MA(CLOSE,3),1);
XA_32:=LOW>REF(LOW,2);
XA_33:=VOL>REF(VOL,1)*0.6 AND VOL<REF(VOL,1)*1.3;
XA_34:=REF(LOW,1)>REF(LOW,2)*0.985;
XA_35:=VOL<=MA(VOL,60);
XA_36:=REF(CLOSE,1)/REF(MA(CLOSE,5),1)<1.05;
XA_37:=HIGH<REF(HIGH,5);
XA_38:=MAX(OPEN,CLOSE)/MIN(OPEN,CLOSE)<1.06;
XA_39:=MA(CLOSE,20)/CLOSE>1.09;
XA_40:=EMA(CLOSE,60)/CLOSE>1.08 AND EMA(CLOSE,60)/CLOSE<1.25;
XA_41:=REF(CLOSE,5)/CLOSE>1.025;
XA_42:=CLOSE/LOW<1.035;
XA_43:=REF(VOL,5)>VOL*0.8;
XA_44:=REF(VOL,4)<VOL*2;
XA_45:=REF(OPEN,1)<=REF(CLOSE,2)*1.02;
XA_46:=OPEN<REF(CLOSE,1)*1.002;
XA_47:=MAX(OPEN,CLOSE)/MIN(OPEN,CLOSE)<1.04;
XA_48:=CLOSE-REF(CLOSE,10);
XA_49:=EMA(XA_48,6);
XA_50:=XA_49>REF(XA_48,1)*0.97;
XA_51:=FILTER(XA_30 AND XA_31 AND XA_33 AND XA_34 AND XA_38 AND XA_39 AND XA_41 AND XA_42 AND XA_43 AND XA_44 AND XA_40 AND XA_45 AND XA_46 AND XA_50,2);
XG:XA_28 OR XA_51,COLORRED,LINETHICK2;

通达信今买明卖超级短线选股公式源码