通达信金钻挖掘机副图指标公式源码免费下载

通达信金钻挖掘机副图指标公式源码:

{公式源码:}
XA_1:=REF(COUNT(CLOSE/REF(CLOSE,1)>1.095 AND LOW<MA(CLOSE,250) AND CLOSE>MA(CLOSE,250),10)=1,1);
XA_2:=MA(CLOSE,5);
XA_3:=MA(CLOSE,10);
XA_4:=MA(CLOSE,20);
XA_5:=MA(CLOSE,60);
XA_6:=MA(CLOSE,250);
XA_7:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);
XA_8:=EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);
XA_9:=EVERY(XA_7>XA_8,10);
XA_10:=COUNT(CLOSE>REF(CLOSE,1),5)/30*100;
XA_11:=MA(XA_10,3);
XA_12:=XA_9 AND CROSS(CLOSE,XA_4) AND XA_5>XA_6 AND XA_4>XA_5 AND XA_2>XA_3 AND XA_3>XA_4;
XA_13:=27;
XA_14:=23;
XA_15:=100*(HHV(HIGH,XA_13)-CLOSE)/(HHV(HIGH,XA_13)-LLV(LOW,XA_13));
XA_16:=100*(HHV(HIGH,XA_14)-CLOSE)/(HHV(HIGH,XA_14)-LLV(LOW,XA_14));
XA_17:=CLOSE*VOL;
XA_18:=EMA((EMA(XA_17,3)/EMA(VOL,3)+EMA(XA_17,6)/EMA(VOL,6)+EMA(XA_17,12)/EMA(VOL,12)+EMA(XA_17,24)/EMA(VOL,24))/4,13);
XA_19:=1.08*XA_18;
XA_20:=EMA(XA_19-(EMA(CLOSE,3)-XA_19),5);
XA_21:=IF(XA_20<=XA_19,XA_20,XA_19);
XA_22:=2*XA_19-XA_15;
XA_23:=IF(XA_22>=XA_19,XA_22,XA_19);
XA_24:=EVERY(MACD.MACD>0,20) AND XA_16<=0 AND REF(XA_15>0,1) AND LOW<XA_21;
STICKLINE(XA_24>0,15,1*0.6,2,0),COLOR0080FF;

通达信金钻挖掘机副图指标公式源码注释:

XA_1赋值:1日前的统计10日中满足收盘价/1日前的收盘价>1.095ANDLOW<收盘价的250日简单移动平均ANDCLOSE>收盘价的250日简单移动平均的天数=1
XA_2赋值:收盘价的5日简单移动平均
XA_3赋值:收盘价的10日简单移动平均
XA_4赋值:收盘价的20日简单移动平均
XA_5赋值:收盘价的60日简单移动平均
XA_6赋值:收盘价的250日简单移动平均
XA_7赋值:100*(收盘价-34日内最低价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的3日指数移动平均
XA_8赋值:100*(大盘的收盘价-34日内大盘的最低价的最低值)/(34日内大盘的最高价的最高值-34日内大盘的最低价的最低值)的3日指数移动平均
XA_9赋值:最近10日一直存在XA_7>XA_8
XA_10赋值:统计5日中满足收盘价>1日前的收盘价的天数/30*100
XA_11赋值:XA_10的3日简单移动平均
XA_12赋值:XA_9 AND 收盘价上穿XA_4 AND XA_5>XA_6 AND XA_4>XA_5 AND XA_2>XA_3 AND XA_3>XA_4
XA_13赋值:27
XA_14赋值:23
XA_15赋值:100*(XA_13日内最高价的最高值-收盘价)/(XA_13日内最高价的最高值-XA_13日内最低价的最低值)
XA_16赋值:100*(XA_14日内最高价的最高值-收盘价)/(XA_14日内最高价的最高值-XA_14日内最低价的最低值)
XA_17赋值:收盘价*成交量(手)
XA_18赋值:(XA_17的3日指数移动平均/成交量(手)的3日指数移动平均+XA_17的6日指数移动平均/成交量(手)的6日指数移动平均+XA_17的12日指数移动平均/成交量(手)的12日指数移动平均+XA_17的24日指数移动平均/成交量(手)的24日指数移动平均)/4的13日指数移动平均
XA_19赋值:1.08*XA_18
XA_20赋值:XA_19-(收盘价的3日指数移动平均-XA_19)的5日指数移动平均
XA_21赋值:如果XA_20<=XA_19,返回XA_20,否则返回XA_19
XA_22赋值:2*XA_19-XA_15
XA_23赋值:如果XA_22>=XA_19,返回XA_22,否则返回XA_19
XA_24赋值:最近20日一直存在平滑异同平均线的MACD>0 AND XA_16<=0 AND 1日前的XA_15>0 AND 最低价<XA_21
当满足条件XA_24>0时,在15和1*0.6位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR0080FF

通达信金钻挖掘机选股公式源码:

{选股公式源码:}
XA_1:=REF(COUNT(CLOSE/REF(CLOSE,1)>1.095 AND LOW<MA(CLOSE,250) AND CLOSE>MA(CLOSE,250),10)=1,1);
XA_2:=MA(CLOSE,5);
XA_3:=MA(CLOSE,10);
XA_4:=MA(CLOSE,20);
XA_5:=MA(CLOSE,60);
XA_6:=MA(CLOSE,250);
XA_7:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);
XA_8:=EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);
XA_9:=EVERY(XA_7>XA_8,10);
XA_10:=COUNT(CLOSE>REF(CLOSE,1),5)/30*100;
XA_11:=MA(XA_10,3);
XA_12:=XA_9 AND CROSS(CLOSE,XA_4) AND XA_5>XA_6 AND XA_4>XA_5 AND XA_2>XA_3 AND XA_3>XA_4;
XA_13:=27;
XA_14:=23;
XA_15:=100*(HHV(HIGH,XA_13)-CLOSE)/(HHV(HIGH,XA_13)-LLV(LOW,XA_13));
XA_16:=100*(HHV(HIGH,XA_14)-CLOSE)/(HHV(HIGH,XA_14)-LLV(LOW,XA_14));
XA_17:=CLOSE*VOL;
XA_18:=EMA((EMA(XA_17,3)/EMA(VOL,3)+EMA(XA_17,6)/EMA(VOL,6)+EMA(XA_17,12)/EMA(VOL,12)+EMA(XA_17,24)/EMA(VOL,24))/4,13);
XA_19:=1.08*XA_18;
XA_20:=EMA(XA_19-(EMA(CLOSE,3)-XA_19),5);
XA_21:=IF(XA_20<=XA_19,XA_20,XA_19);
XA_22:=2*XA_19-XA_15;
XA_23:=IF(XA_22>=XA_19,XA_22,XA_19);
EVERY(MACD.MACD>0,20) AND XA_16<=0 AND REF(XA_15>0,1) AND LOW<XA_21;

通达信金钻挖掘机指标使用说明:

首先您需要先了解指标的信号位置,是否适合您的操作习惯和持股盈亏的心理预期;

我们需要根据指标建立一个交易模型;建立交易模型是为了更好的买入卖出操作;

一般来说根据不同的指标出信号的位置是不一样的;这个时候我们需要根据自己的操作思维、

习惯、心理预期做出不同的判断;

判断如下: 一、出信号的票是否当前热门题材;

二、出信号位置是否在自己的心理预期位置;

三、当前行情总体走势是否值得操作;

建议出信号后,尽量配合当前当天的热点题材,另外要注意个股是否有黑天鹅或者利空消息;

当经过我们的判断后,就可以根据自己的资金仓位进行操作;一般来说短线操作建议分仓进行;

对于资金多的来说,仓位尽量控制在三成仓以下;资金少的建议适度谨慎后重仓一些;

短线操作:指标出信号后介入时机,建议根据当前日内行情走向,分时线逢低介入,或者下午2点半以后做操作决策;

如果当天行情较弱或者受利空影响比较大,建议先观望,隔天择机介入;当天行情走势比较平稳或者较强,建议逢低

介入;

短线卖出时机,隔天获利即走;短线操作要的是不断的成功复利,而不是一只票的翻倍;

别因为贪图小利,导致本来赚钱的票,结果亏损割肉出局这样就不好了;

记住股市永远不缺机会,缺的是耐心和信心。

尽量在大盘正常下使用,行情下跌中建议不用,每天选出个股数量不 要超过5只,
如果出现选出个股数量很多说明行情不好,不建议操作;
另外说明:出信号后尽量逢低关注,隔天即便没有拉升,未来一周左右基本上都会拉升的,
尽量在指数稳定或者上升期做,遇到指数大幅度回调的时候,尽量多观察2-3天止跌后介入效果最好;
出信号当天盘中或者尾盘逢低介入;
隔天如果拉升比较强势可持股继续待涨,如果隔天拉升无力,建议找机会微利或者平盘出局;
继续寻找下一只个股机会; 建议出信号后,尽量配合当前当天的热点题材,
另外要注意个股是否有黑天鹅或者利空消息;
关于指标出信号操作:在目前市场行情中,为了资金安全建议出信号分仓操作;
首次买入建议不超过2成仓位,获利即可止盈了结;
如果买入后回调首次补仓建议交易软件内(即实际持仓成本)下跌10%补一成即可;
如果继续回调,关注前一个波段的最低启动点,
补仓至交易软件内的低于亏损10%左右即可(即总体亏损低于或者等于10%);此时持仓数量不应超过总仓位7成;
如果该信号个股类似这种走势,可以最少获利在15%左右;