萧啸多空_副图指标公式源码

以下是萧啸多空副图指标公式源码:

DRAWTEXT_FIX(1,0.00,0.15,0,'指标网:WWW.ZHIBIAOW.COM '),COLORYELLOW;
NOTEXT安全线:20,DOTLINE,COLORGREEN;
NOTEXT平衡线:50,DOTLINE,COLORWHITE;
NOTEXT风险线:80,COLORRED;
X_1:=LLV(LOW,6);
X_2:=HHV(HIGH,6);
NOTEXT快多:EMA((CLOSE-X_1)/(X_2-X_1)*100,13),COLORRED;
NOTEXT快空:EMA(0.618*REF(NOTEXT快多,1)+0.382*NOTEXT快多,3),COLORYELLOW;
DRAWICON(CROSS(NOTEXT快多,NOTEXT快空),NOTEXT快空,1);
DRAWICON(CROSS(NOTEXT快空,NOTEXT快多),NOTEXT快多,2);
NOTEXT安全线1:(-20),DOTLINE,COLORRED;
NOTEXT平衡线1:(-50),DOTLINE,COLORWHITE;
NOTEXT风险线1:(-80),COLORGREEN;
X_3:=LLV(LOW,18);
X_4:=HHV(HIGH,18);
NOTEXT慢多:-ABS(100-EMA((CLOSE-X_3)/(X_4-X_3)*100,13)),COLORRED;
NOTEXT慢空:-ABS(EMA(0.618*REF(NOTEXT慢多,1)+0.382*NOTEXT慢多,3)),COLORYELLOW;
DRAWICON(CROSS(NOTEXT慢多,NOTEXT慢空),NOTEXT慢空,1);
DRAWICON(CROSS(NOTEXT慢空,NOTEXT慢多),NOTEXT慢多,2);
X_5:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
X_6:=IF(MA(CLOSE,17)<X_5,X_5,MA(CLOSE,17));
X_7:=EMA(CLOSE,3);
X_8:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));
X_9:=X_6-(X_7-X_6);
X_10:=IF(X_9>X_8,X_9,DRAWNULL);
X_11:=IF(X_9>REF(X_9,1),X_9,DRAWNULL);
IF(X_6-(X_7-X_6),0,DRAWNULL),COLORMAGENTA,LINETHICK8;
IF(X_9>X_8,0,DRAWNULL),COLORYELLOW,LINETHICK8;
IF(X_9>REF(X_9,1),0,DRAWNULL),COLORGREEN,LINETHICK8;
X_12:=IF(SUM(VOL/CAPITAL,20)<1,SUM(VOL/CAPITAL,20),0.998);
X_13:=DMA(EMA(CLOSE,13),X_12);
X_14:=(CLOSE-X_13)/X_13*100;
X_15:=SMA(X_14,3,1);
IF(X_15>REF(X_15,1),6,DRAWNULL),COLORRED,LINETHICK4;