通达信牛熊先知主图指标公式源码

以下是指标网提供的通达信牛熊先知主图指标公式源码:

DRAWGBK(O>C,RGB(48,41,124),RGB(0,0,0),0,'1',0);
A1:EMA(CLOSE,21),COLORRED,LINETHICK2;
IF(A1>REF(A1,1),A1,DRAWNULL),LINETHICK2,COLORRED;
IF(A1<REF(A1,1),A1,DRAWNULL),LINETHICK2,COLORGREEN;
A2:=EMA(CLOSE,34),COLORWHITE,LINETHICK2;
A3:=EMA(CLOSE,55),COLORRED,LINETHICK2;
DRAWBAND(A2,RGB(220,200,20),A3,RGB(220,200,20));
A4:=EMA(CLOSE,89),COLORRED,LINETHICK2;
A5:=EMA(CLOSE,105),COLORRED,LINETHICK2;
DRAWBAND(A4,RGB(150,50,150),A5,RGB(150,50,150));
A6:=EMA(CLOSE,135),COLORRED,LINETHICK2;
A7:=EMA(CLOSE,155),COLORRED,LINETHICK2;
DRAWBAND(A6,RGB(220,50,55),A7,RGB(220,50,55));
STICKLINE(C>O,H,L,0,0),COLORRED;
STICKLINE(C>O,O,C,3,1),COLORRED;
STICKLINE(C<O,H,L,0,0),COLORFFEE00;
STICKLINE(C<O,O,C,3,0),COLORFFEE00;
STICKLINE(C=O,H,L,0,0),COLORWHITE;
STICKLINE(C=O,C,O,3,0),COLORWHITE;
STICKLINE((C-REF(C,1))/REF(C,1)>0.095,C,O,1,0),COLORYELLOW;
MA3:=EMA(CLOSE,5),COLORRED,LINETHICK1;
MA5:=EMA(CLOSE,7),COLORGREEN,LINETHICK1;
MA10:=EMA(CLOSE,13),COLORLIBLUE,LINETHICK1;
AA:=CROSS(MA3,MA5) AND MA5>REF(MA5,1) AND MA10>REF(MA10,1);
DRAWICON(AA,L*0.98,1);
DRAWTEXT(AA,L*0.98,'←●●●'),COLORYELLOW;