通达信懒人炒股副图指标公式源码

以下是指标网提供的通达信懒人炒股副图指标公式源码:

JJ:=(CLOSE+HIGH+LOW+OPEN)/4;
A:=EMA(JJ,13);
B:=EMA(JJ,4);
A1:STICKLINE(A>REF(A,1) AND REF(A,1)>REF(A,2),A,REF(A,1),3,1),COLORRED;
A2:STICKLINE(A>REF(A,1) AND REF(A,1)<REF(A,2),A,REF(A,1),3,1),COLORRED;
A3:STICKLINE(A>REF(A,1) AND REF(A,1)<REF(A,2),A,REF(A,1),3,1),COLORRED;
A4:STICKLINE(A<REF(A,1),A,REF(A,1),3,0),COLORCYAN;
NOTEXT1:(20*B+19*REF(B,1)+18*REF(B,2)+17*REF(B,3)+16*REF(B,4)+15*REF(B,5)+14*REF(B,6)+13*REF(B,7)+12*REF(B,8)+11*REF(B,9)+10*REF(B,10)+9*REF(B,11)+8*REF(B,12)+7*REF(B,13)+6*REF(B,14)+5*REF(B,15)+4*REF(B,16)+3*REF(B,17)+2*REF(B,18)+REF(B,20))/210,COLORRED;
NOTEXT2:IF(NOTEXT1<=REF(NOTEXT1,1),NOTEXT1,DRAWNULL),COLORCYAN;
NOTEXT3:IF(NOTEXT1>REF(NOTEXT1,1),NOTEXT1,DRAWNULL),COLORRED;
NOTEXT4:IF(NOTEXT1>REF(NOTEXT1,1),EMA(NOTEXT1,2),DRAWNULL),COLORRED,LINETHICK2;