通达信今买明卖超短线副图指标公式源码

通达信今买明卖短线副图指标公式源码:

X_1:=(EMA(CLOSE,5)*7+EMA(CLOSE,10)*3)/10;
X_2:=EMA(EMA(LOW,21)+6.8*STD(LOW,2),55);
X_3:=EMA(CLOSE/X_2*(1.88*CLOSE+LOW+OPEN)/2.75,3);
X_4:=(X_3-X_2)/X_2/2;
X_5:=EMA(X_3-X_4*X_3,5);
X_6:=EMA(CLOSE,300)-3*STD(CLOSE,450);
X_7:=IF(X_1>X_5,X_1,X_5)*0.94;
X_8:=NAMELIKE(1) OR NAMELIKE(2);
X_9:=FINANCE(43)>0 AND FINANCE(30)>0;
X_10:=CLOSE<REF(LLV(LOW,4),1) AND COUNT(HIGH>X_7,8)>4 AND COUNT(CLOSE>X_7,100)<30 AND COUNT(LOW<X_7,10)>2;
X_11:=FILTER(REF(X_10=1,1) AND CLOSE>OPEN AND X_9 AND NOT(X_8),2) AND COUNT(CLOSE/REF(CLOSE,1)>1.09,15)<3;
STICKLINE(X_11,0,0.2,6,0),COLORMAGENTA;
STICKLINE(X_11,0.2,0.4,4,0),COLORRED;
STICKLINE(X_11,0.4,0.6,3,0),COLORBLUE;
STICKLINE(X_11,0.6,0.8,2,0),COLORGREEN;
STICKLINE(X_11,0.8,1,0,0),COLORYELLOW;