萧啸擒龙捉妖X 主图指标公式源码

{公式名称: 萧啸擒龙捉妖X
公式描述:
无参数
公式类型: 技术指标公式-其他类型
画线方法: 主图叠加
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:无
用法注释:无
公式源码:}
X_1:=EMA(CLOSE,7);
X_2:=EMA(CLOSE,18);
X_3:=(X_1-X_2)/X_2*100;
X_4:=EMA(X_3,1);
X_5:=EMA(CLOSE,3);
X_6:=EMA(CLOSE,26);
X_7:=X_5-X_6;
DK:EMA(EMA(EMA(CLOSE,3),3),3)+X_7,COLORGREEN;
IF(X_4>=REF(X_4,1),DK,DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(X_4<=REF(X_4,1),DK,DRAWNULL),COLORGREEN;
X_8:=HHV(VOL,5);
X_9:=OPEN>CLOSE;
X_10:=CLOSE>OPEN;
X_11:=CLOSE=OPEN;
X_12:=SUM(VOL,5)/X_8;
X_13:=IF(X_12>0.3,1,0);
X_14:=IF(X_9 AND X_13,VOL,0);
X_15:=IF(X_10 AND X_13,VOL,0);
X_16:=IF(X_11 AND X_13,VOL,0);
X_17:=SUM(X_15,3);
X_18:=SUM(X_14,3);
X_19:=X_17-X_18;
STICKLINE(X_19=X_17,CLOSE,OPEN,3.05,0),COLOR000099;
STICKLINE(X_19=X_17,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(X_19=X_17,CLOSE,OPEN,1.5,0),COLORRED;
STICKLINE(X_19=X_17,CLOSE,OPEN,0.5,0),COLORYELLOW;
DRAWICON(X_19=X_17 AND REF(X_19=X_17,1)=0,LOW*0.98,30),COLORMAGENTA;
X_20:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);
X_21:=(REF(X_20,1)+REF(X_20,2)+REF(X_20,3))/3;
X_22:=(REF(X_20,1)+REF(X_20,2)+REF(X_20,3)+REF(X_20,4)+REF(X_20,5)+REF(X_20,6)+REF(X_20,7)+REF(X_20,8)+REF(X_20,9)+REF(X_20,10))/10;
X_23:=X_20<80 AND X_21<80 AND X_22<80;
X_24:=X_20>80 AND X_21>80 AND X_22>80;
X_25:=X_22<X_20;
X_26:=REF(CLOSE,1);
X_27:=SMA(MAX(CLOSE-X_26,0),2,1)/SMA(ABS(CLOSE-X_26),2,1)*100;
X_28:=100*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10));
X_29:=100*(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6));
X_30:=CROSS(X_27,X_29) AND X_25;
X_31:=X_27>75 AND X_29<5;
DRAWICON(X_31 AND X_17>X_19,LOW*0.99,29),COLORYELLOW;
DRAWICON(X_30,LOW*0.98,28),COLORYELLOW;
X_32:=WINNER(CLOSE*0.9)*100;
X_33:=MA(X_32,10);
X_34:=MA(X_32,3);
X_35:=IF(X_33>X_34,X_34,X_33);
X_36:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*50;
X_37:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_38:=EMA(X_37,9);
X_39:=X_37>X_38;
X_40:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
X_41:=SMA(X_36,3,1);
X_42:=SMA(X_41,3,1);
X_43:=X_41>X_42;
X_44:=REF(CLOSE,1);
X_45:=SMA(MAX(CLOSE-X_44,0),9,1)/SMA(ABS(CLOSE-X_44),9,1)*100;
X_46:=SMA(MAX(CLOSE-X_44,0),26,1)/SMA(ABS(CLOSE-X_44),26,1)*100;
X_47:=X_45>X_46;
X_48:=SMA(X_40,3,1);
X_49:=SMA(X_48,3,1);
X_50:=X_48>X_49;
X_51:=(MA(CLOSE,3)+MA(CLOSE,9)+MA(CLOSE,12)+MA(CLOSE,26))/4;
X_52:=CLOSE>X_51;
X_53:=CLOSE-REF(CLOSE,1);
X_54:=100*EMA(EMA(X_53,9),9)/EMA(EMA(ABS(X_53),9),3);
X_55:=100*EMA(EMA(X_53,26),12)/EMA(EMA(ABS(X_53),26),12);
X_56:=X_54>X_55;
X_57:=X_39 AND X_43 AND X_47 AND X_50 AND X_52 AND X_56;
X_58:=EMA(EMA(CLOSE,9),9);
X_59:=100*WINNER(CLOSE*0.95);
X_60:=EMA(CLOSE,12)>EMA(CLOSE,50) AND EMA(CLOSE,20)>EMA(CLOSE,120);
X_61:=(X_58-REF(X_58,1))/REF(X_58,1)*1000;
X_62:=X_59>=50 AND COST(85)<=CLOSE AND X_61>0 AND X_61>REF(X_61,1);
X_63:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
X_64:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
X_65:=IF(CLOSE>OPEN,X_64*(HIGH-LOW),IF(CLOSE<OPEN,X_64*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-X_64*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-X_64*(HIGH-LOW),0-VOL/2));
X_66:=X_65/20/1.15;
X_67:=X_66*0.55+REF(X_66,1)*0.33+REF(X_66,2)*0.22;
X_68:=EMA(X_67,8);
X_69:=EMA(X_67,3);
X_70:=X_69;
X_71:=MA(VOL,5);
X_72:=MA(VOL,10);
X_73:=X_71>=X_72;
X_74:=X_70>=0;
X_75:=X_74 AND X_73;
X_76:=X_57 OR X_75;
X_77:=CROSS(REF(CLOSE,1),CLOSE);
X_78:=WINNER(CLOSE)*100;
X_79:=REF(X_78,1)-X_78<=5;
X_80:=CROSS(X_78,REF(X_78,1)) AND X_78<20;
X_81:=X_79 OR X_78;
X_82:=X_77 AND X_81;
X_83:=(2*CLOSE+HIGH+LOW)/4;
X_84:=LLV(LOW,5);
X_85:=HHV(HIGH,5);
X_86:=IF((MA(CLOSE,5)-CLOSE)/CLOSE>0.04 AND (MA(CLOSE,10)-MA(CLOSE,5))/MA(CLOSE,5)>0.04,23,0);
X_87:=X_86=23;
X_88:=BARSLAST(X_87)=1;
X_89:=X_86<23;
X_90:=X_88 AND X_89;
X_91:=(BARSLASTCOUNT(X_86>0)=4)*30;
X_92:=X_90 OR X_91;
X_93:=EMA(VOL,13);
X_94:=EMA(AMOUNT,13);
X_95:=X_94/X_93/100;
X_96:=(CLOSE-X_95)/X_95*100;
X_97:=X_96<0-18 OR X_96<0-6;
X_98:=X_97 AND X_92;
X_99:=X_98 OR X_82;
STICKLINE(X_99 AND X_22<80 AND X_35=X_33 AND X_76,LOW,OPEN,3,0),COLORBLUE;
STICKLINE(X_99 AND X_22<80 AND X_35=X_33 AND X_76,CLOSE,OPEN,3,0),COLORMAGENTA;
X_100:=REF(LOW,1);
X_101:=SMA(ABS(LOW-X_100),3,1)/SMA(MAX(LOW-X_100,0),3,1)*100;
X_102:=EMA(IF(CLOSE*1.3,X_101*10,X_101/10),3);
X_103:=LLV(LOW,13);
X_104:=HHV(X_102,13);
X_105:=IF(MA(CLOSE,34),1,0);
X_106:=EMA(IF(LOW<=X_103,(X_102+X_104*2)/2,0),3)/618*X_105;
X_107:=IF(X_106>100,100,X_106);
X_108:=X_107>15 AND X_76;
X_109:=X_108 OR X_107=100;
STICKLINE(X_109,LOW,OPEN,3,0),COLORMAGENTA;
STICKLINE(X_109,CLOSE,OPEN,3,0),COLORBLUE;
X_110:=EMA(CLOSE,2);
X_111:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
X_112:=IF(CROSS(X_110,X_111),LOW-0.02,DRAWNULL);
X_113:=(LOW+HIGH+CLOSE*2)/4;
X_114:=EMA(X_113,14);
X_115:=(X_114-REF(X_114,1))/REF(X_114,1)*100;
X_116:=IF(X_115>=0,X_114,DRAWNULL);
X_117:=IF(CROSS(X_112,0),5,0);
X_118:=IF(CROSS(X_116,0),10,0);
X_119:=X_117 AND X_118;
DRAWICON(X_119,LOW*0.99,1),COLORGREEN;
DRAWICON(X_119,LOW*0.98,1),COLORGREEN;
X_120:=REF(CLOSE,1);
X_121:=SMA(MAX(CLOSE-X_120,0),5,1)/SMA(ABS(CLOSE-X_120),5,1)*100;
X_122:=CROSS(80,X_121);
DRAWICON(X_122,HIGH*1.01,2),COLORGREEN;
DRAWICON(X_122,HIGH*1.02,2),COLORGREEN;
X_123:=SMA(MAX(CLOSE-X_26,0),3,1)/SMA(ABS(CLOSE-X_26),3,1)*100;
X_124:=EMA(CLOSE,3);
X_125:=EMA(CLOSE,21);
DRAWICON(CROSS(X_124,X_125),LOW*0.97,38),COLORRED;
DRAWICON(CROSS(88,X_123),HIGH*1.03,39),COLORYELLOW;
X_126:=8;
X_127:=100*EMA(EMA(X_53,X_126),X_126)/EMA(EMA(ABS(X_53),X_126),X_126);
X_128:=IF(LLV(X_127,2)=LLV(X_127,7) AND COUNT(X_127<0,2) AND CROSS(X_127,MA(X_127,2)),1,0);
DRAWICON(FILTER(X_128=1,5),LOW*0.99,7),COLORRED;
X_129:=CLOSE-REF(CLOSE,1);
X_130:=IF(CLOSE-REF(CLOSE,1)>=0,X_129,0);
X_131:=REF(CLOSE,1)-CLOSE;
X_132:=IF(CLOSE-REF(CLOSE,1)<=0,X_131,0);
X_133:=SUM(X_130,90)/SUM(X_132,90);
X_134:=100-100/(1+X_133);
X_135:=EMA(X_134,21);
X_136:=EMA(X_135,5);
X_137:=EMA(X_135,3);
X_138:=(CLOSE*2+HIGH+LOW)/4;
X_139:=EMA(X_138,13)-EMA(X_138,21);
X_140:=EMA(X_139,3);
X_141:=EMA(X_139,10);
X_142:=IF(X_140>=X_141,X_140,X_141);
X_143:=IF(X_141-X_140,X_141,X_140);
X_144:=EMA(CLOSE,7)-EMA(CLOSE,21);
X_145:=EMA(0.668*REF(X_144,1)+0.333*X_144,1);
X_146:=IF(X_144>=X_145,X_144,X_145);
X_147:=IF(X_145-X_144,X_145,X_144);
X_148:=X_142>X_143;
X_149:=X_142=X_143;
X_150:=X_146>X_147;
X_151:=X_146=X_147;
X_152:=X_151 AND X_149;
X_153:=X_150 AND X_148;
STICKLINE(X_150,HIGH,LOW,0,0),COLORRED;
STICKLINE(X_151,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(X_148,OPEN,CLOSE,1,0),COLORRED;
STICKLINE(X_149,OPEN,CLOSE,1,0),COLORGREEN;
STICKLINE(X_153,OPEN,CLOSE,2,0),COLORRED;
STICKLINE(X_152,OPEN,CLOSE,2,0),COLORBLUE;
X_154:=HHV(MA(HIGH,3),2);
UP:LLV(MA(HIGH,3),1),COLORRED;
DOWN:IF(X_154-UP>0,UP,DRAWNULL),COLORGREEN;
X_155:=MA(REF(HHV((CLOSE+LOW+OPEN+HIGH)/4,30),1),3);
STICKLINE(REF(COUNT(CLOSE<X_155,5)=5,1) AND CLOSE>X_155 AND CLOSE>OPEN,CLOSE,OPEN,2,0),COLORYELLOW;
DRAWICON(REF(COUNT(CLOSE<X_155,5)=5,1) AND CLOSE>X_155 AND CLOSE>OPEN,LOW,42),COLORRED;
X_156:=MA(CLOSE,60)>REF(MA(CLOSE,60),1);
X_157:=COST(50);
X_158:=WINNER(CLOSE)*100>50;
X_159:=CROSS(CLOSE,X_157);
X_160:=X_156 AND X_157 AND X_158 AND X_159 AND X_150;
STICKLINE(X_160,CLOSE,OPEN,1,0),COLORMAGENTA;
DRAWICON(X_160,LOW*0.99,44),COLORRED;
X_161:=MA(CLOSE,10);
X_162:=MA(CLOSE,54);
STICKLINE(CLOSE/REF(CLOSE,1)>=1.096 AND HIGH=CLOSE,OPEN,CLOSE,2,0),COLORYELLOW;
X_163:=EMA(CLOSE,5);
X_164:=EMA(X_163,0);
X_165:=HHV(MA(HIGH,3),2);
X_166:=LLV(MA(HIGH,3),1);
DRAWICON(X_166=X_165 AND REF(X_165,1)>REF(X_166,1) AND X_150,LOW,1);
DRAWICON(X_166<X_165 AND REF(X_166=X_165,1) AND X_151,HIGH*1.01,2);
X_167:=MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>REF(MA(CLOSE,10),1) AND MA(CLOSE,5)>REF(MA(CLOSE,5),1);
X_168:=100*(1-WINNER(CLOSE));
X_169:=100-X_168;
X_170:=CROSS(X_169,X_168);
DRAWICON(X_170,LOW,25);
X_171:=MA(CLOSE,5);
X_172:=MA(CLOSE,13);
X_173:=MA(CLOSE,34);
X_174:=X_171>REF(X_171,1) AND X_172>REF(X_172,1) AND X_173>REF(X_173,1);
X_175:=EMA(CLOSE,3);
X_176:=EMA(SLOPE(CLOSE,34)*5+CLOSE,21);
X_177:=CROSS(X_175,X_176);
X_178:=CROSS(X_175,X_176) AND X_174;
X_179:=X_177>0;
X_180:=X_178>0;
X_181:=MA(CLOSE,34);
X_182:=X_179 OR X_180;
X_183:=CLOSE>X_181 AND REF(CLOSE,1)<X_181;
X_184:=CROSS(CLOSE,MA(CLOSE,250)) AND VOL>=REF(VOL,1)*2;
X_185:=(CLOSE/REF(CLOSE,1)-1)*100>9.97 AND CROSS(CLOSE,MA(CLOSE,250));
X_186:=X_184 OR X_185 OR X_183;
X_187:=X_182 AND X_170 AND X_186 AND X_167;
STICKLINE(X_187,CLOSE,OPEN,3.05,0),COLOR000099;
STICKLINE(X_187,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(X_187,CLOSE,OPEN,1.5,0),COLORRED;
STICKLINE(X_187,CLOSE,OPEN,0.5,0),COLORYELLOW;