萧啸一路筹码 副图指标公式源码

{公式名称: 萧啸一路筹码
公式描述:
无参数
公式类型: 技术指标公式-其他类型
画线方法: 副图
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:无
用法注释:无
公式源码:}
X_1:=WINNER(CLOSE*0.9)*100;
X_2:=100-WINNER(CLOSE*1.1)*100;
X_3:=100-X_1-X_2;
STICKLINE(1,X_1,X_1+X_3,3,0),COLOR009999;
STICKLINE(1,X_1,X_1+X_3,2.5,0),COLOR00AAAA;
STICKLINE(1,X_1,X_1+X_3,2,0),COLOR00BBBB;
STICKLINE(1,X_1,X_1+X_3,1.5,0),COLOR00CCCC;
STICKLINE(1,X_1,X_1+X_3,1,0),COLOR00DDDD;
STICKLINE(1,X_1,X_1+X_3,0.5,0),COLOR00EEEE;
STICKLINE(1,X_1,X_1+X_3,0,0),COLORYELLOW;
STICKLINE(1,0,X_1,3,0),COLOR000077;
STICKLINE(1,0,X_1,2.5,0),COLOR000099;
STICKLINE(1,0,X_1,2,0),COLOR0000AA;
STICKLINE(1,0,X_1,1.5,0),COLOR0000BB;
STICKLINE(1,0,X_1,1,0),COLOR0000DD;
STICKLINE(1,0,X_1,0.5,0),COLOR0000EE;
STICKLINE(1,0,X_1,0,0),COLORRED;
STICKLINE(1,X_1+X_3,100,3,0),COLOR007700;
STICKLINE(1,X_1+X_3,100,2.5,0),COLOR009900;
STICKLINE(1,X_1+X_3,100,2,0),COLOR00AA00;
STICKLINE(1,X_1+X_3,100,1.5,0),COLOR00BB00;
STICKLINE(1,X_1+X_3,100,1,0),COLOR00CC00;
STICKLINE(1,X_1+X_3,100,0.5,0),COLOR00DD00;
STICKLINE(1,X_1+X_3,100,0,0),COLORGREEN;
X_4:=CLOSE-REF(CLOSE,1);
X_5:=100*EMA(EMA(X_4,5),3)/EMA(EMA(ABS(X_4),5),3);
X_6:=100*EMA(EMA(X_4,13),8)/EMA(EMA(ABS(X_4),13),8);
X_7:=X_5>X_6;
X_8:=IF(X_7,6,0);
X_9:=EMA(CLOSE,8)-EMA(CLOSE,13);
X_10:=EMA(X_9,5);
X_11:=X_9>X_10;
X_12:=IF(X_11,1,0);
X_13:=(EMA(CLOSE,3)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4;
X_14:=CLOSE>X_13;
X_15:=IF(X_14,5,0);
X_16:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
X_17:=SMA(X_16,3,1);
X_18:=SMA(X_17,3,1);
X_19:=X_17>X_18;
X_20:=IF(X_19,2,0);
X_21:=REF(CLOSE,1);
X_22:=SMA(MAX(CLOSE-X_21,0),5,1)/SMA(ABS(CLOSE-X_21),5,1)*100;
X_23:=SMA(MAX(CLOSE-X_21,0),13,1)/SMA(ABS(CLOSE-X_21),13,1)*100;
X_24:=X_22>X_23;
X_25:=IF(X_24,3,0);
X_26:=(-(HHV(HIGH,13)-CLOSE))/(HHV(HIGH,13)-LLV(LOW,13))*100;
X_27:=SMA(X_26,3,1);
X_28:=SMA(X_27,3,1);
X_29:=X_27>X_28;
X_30:=IF(X_29,4,0);
X_31:=X_11+X_19+X_24+X_29+X_14+X_7-3;
X_32:=X_31>0;
X_33:=HHV(HIGH,34);
X_34:=LLV(LOW,34);
X_35:=EVERY(CLOSE<OPEN,4);
X_36:=EVERY(CLOSE<OPEN,3);
X_37:=X_35 OR X_36;
X_38:=REF(X_37,1) AND X_33 AND X_34 AND OPEN<MA(CLOSE,5) AND OPEN<MA(CLOSE,10) AND CLOSE>=MA(CLOSE,5) AND CLOSE>=MA(CLOSE,10);
X_39:=X_32 AND REF(X_31,1)<=0 AND CROSS(CLOSE,EMA(CLOSE,5)) AND CROSS(CLOSE,EMA(CLOSE,10)) AND CROSS(CLOSE,EMA(CLOSE,20)) AND LOW>REF(LOW,1) AND MACD.MACD>0;
X_40:=X_38 OR X_39;
X_41:=REF(CLOSE,1);
X_42:=SMA(MAX(CLOSE-X_41,0),5,1)/SMA(ABS(CLOSE-X_41),5,1)*100;
X_43:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),10);
X_44:=HIGH-REF(HIGH,1);
X_45:=REF(LOW,1)-LOW;
X_46:=SUM(IF(X_44>0 AND X_44>X_45,X_44,0),10);
X_47:=SUM(IF(X_45>0 AND X_45>X_44,X_45,0),10);
X_48:=X_46*100/X_43;
X_49:=X_47*100/X_43;
X_50:=MA(ABS(X_49-X_48)/(X_49+X_48)*100,5);
X_51:=X_42+X_50;
X_52:=(X_50+REF(X_50,5))/2+X_42;
X_53:=100*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10));
X_54:=X_42-X_53;
X_55:=X_51+X_54;
X_56:=IF(CROSS(X_55,0),1,0);
X_57:=SMA(X_56,3,1);
X_58:=SMA(X_57,3,1);
X_59:=SMA(X_58,3,1);
X_60:=IF(CROSS(X_58,X_59) AND X_58<40,25,0);
X_61:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*50;
X_62:=SMA(X_61,3,1);
X_63:=SMA(X_62,3,1);
X_64:=3*X_62-2*X_63;
X_65:=LLV(X_64,2)=LLV(X_64,8);
X_66:=IF(CROSS(X_64,3),60,0);
X_67:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
X_68:=SMA(X_67,3,1);
X_69:=SMA(X_68,3,1);
X_70:=3*X_68-2*X_69;
X_71:=REVERSE(X_70);
X_72:=REF(MA(CLOSE,1),10)>REF(MA(CLOSE,60),10);
X_73:=IF(CROSS(X_70,X_71) AND X_72,45,0);
X_74:=X_60 AND REF(X_66,1);
X_75:=REF(X_60,1) AND X_66;
X_76:=X_74 OR X_75;
X_77:=ABS(((3.48*CLOSE+HIGH+LOW+OPEN)/5-EMA(CLOSE,20))/EMA(CLOSE,20));
X_78:=DMA((2.15*CLOSE+LOW+HIGH+OPEN)/5,X_77);
X_79:=EMA(X_78,200)*1.26;
X_80:=EMA(X_78,200)*1.18;
X_81:=MA((LOW+HIGH+CLOSE)/3,5);
X_82:=HHV(X_81,60);
X_83:=IF(X_82>REF(X_82,1),X_82,DRAWNULL);
X_84:=CLOSE*VOL;
X_85:=EMA((EXPMA(X_84,3)/EXPMA(VOL,3)+EXPMA(X_84,6)/EXPMA(VOL,6)+EXPMA(X_84,12)/EXPMA(VOL,12)+EXPMA(X_84,24)/EXPMA(VOL,24))/4,13);
X_86:=1.06*X_85;
X_87:=1.13*X_85;
X_88:=MIN(X_83,X_79);
X_89:=MIN(X_86,X_79);
X_90:=MIN(X_83,X_80);
X_91:=MIN(X_86,X_80);
X_92:=REF(CLOSE,1)*1.1-CLOSE<0.01 AND HIGH=CLOSE;
X_93:=CROSS(CLOSE,X_87) AND X_92;
X_94:=90;
X_95:=3;
X_96:=REF(LLV(LOW,X_94),X_95);
X_97:=REFDATE(X_96,DATE);
X_98:=X_97=LOW AND (CLOSE-LOW>OPEN-CLOSE OR OPEN-LOW>CLOSE-OPEN);
X_99:=X_93 OR X_98;
X_100:=HHV(HIGH,34);
X_101:=LLV(LOW,34);
X_102:=EVERY(CLOSE<OPEN,4);
X_103:=EVERY(CLOSE<OPEN,3);
X_104:=X_102 OR X_103;
X_105:=REF(X_104,1) AND X_100 AND X_101 AND OPEN<MA(CLOSE,5) AND OPEN<MA(CLOSE,10) AND CLOSE>=MA(CLOSE,5) AND CLOSE>=MA(CLOSE,10);
X_106:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_107:=EMA(X_106,9);
X_108:=X_106>X_107;
X_109:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
X_110:=SMA(X_109,3,1);
X_111:=SMA(X_110,3,1);
X_112:=X_110>X_111;
X_113:=REF(CLOSE,1);
X_114:=SMA(MAX(CLOSE-X_113,0),9,1)/SMA(ABS(CLOSE-X_113),9,1)*100;
X_115:=SMA(MAX(CLOSE-X_113,0),26,1)/SMA(ABS(CLOSE-X_113),26,1)*100;
X_116:=X_114>X_115;
X_117:=SMA(X_109,3,1);
X_118:=SMA(X_117,3,1);
X_119:=X_117>X_118;
X_120:=(MA(CLOSE,3)+MA(CLOSE,9)+MA(CLOSE,12)+MA(CLOSE,26))/4;
X_121:=CLOSE>X_120;
X_122:=CLOSE-REF(CLOSE,1);
X_123:=100*EMA(EMA(X_122,9),9)/EMA(EMA(ABS(X_122),9),3);
X_124:=100*EMA(EMA(X_122,26),12)/EMA(EMA(ABS(X_122),26),12);
X_125:=X_123>X_124;
X_126:=X_108 AND X_112 AND X_116 AND X_119 AND X_121 AND X_125;
STICKLINE(X_126,100,108,3,0),COLORMAGENTA;
X_127:=EMA(EMA(CLOSE,9),9);
X_128:=100*WINNER(CLOSE*0.95);
X_129:=EMA(CLOSE,12)>EMA(CLOSE,50) AND EMA(CLOSE,20)>EMA(CLOSE,120);
X_130:=(X_127-REF(X_127,1))/REF(X_127,1)*1000;
X_131:=X_128>=50 AND COST(85)<=CLOSE AND X_130>0 AND X_130>REF(X_130,1);
X_132:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
X_133:=REF(EMA(X_132,3),1);
X_134:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
X_135:=IF(CLOSE>OPEN,X_134*(HIGH-LOW),IF(CLOSE<OPEN,X_134*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-X_134*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-X_134*(HIGH-LOW),0-VOL/2));
X_136:=X_135/20/1.15;
X_137:=X_136*0.55+REF(X_136,1)*0.33+REF(X_136,2)*0.22;
X_138:=EMA(X_137,8);
X_139:=EMA(X_137,3);
X_140:=X_139;
X_141:=MA(VOL,5);
X_142:=MA(VOL,10);
X_143:=X_141>=X_142;
X_144:=X_140>=0;
X_145:=X_144 AND X_143;
X_146:=MA(KDJ.K#WEEK(9,3,3),5);
X_147:=EMA(CLOSE,12/2)-EMA(CLOSE,26/2);
X_148:=EMA(X_147,9/2);
X_149:=X_146>=REF(X_146,1) AND X_147>=X_148;
股:(-8),COLORRED;
X_150:=EMA(CLOSE,3);
X_151:=EMA(CLOSE,5);
X_152:=EMA(X_151,5);
X_153:=COUNT(CROSS(X_150,X_152),2)=1;
X_154:=COUNT(CROSS(X_151,X_152),2)=1;
X_155:=FILTER(X_153 AND X_154,2);
市:MA(X_1,10),COLORGREEN,LINETHICK4;
X_156:=CROSS(X_1,市) AND 市>REF(市,1);
X_157:=MA(X_1,3);
长:IF(市>X_157,X_157,市),COLORMAGENTA,LINETHICK4;
虹:118,COLORRED;
X_158:=CROSS(X_1,长) AND REF(长,1)<长 AND X_1<长;
X_159:=长=市 AND REF(长<市,1) AND X_1>长;
X_160:=X_158 AND X_156;
X_161:=CROSS(市,X_1) OR CROSS(长,X_1);
X_162:=X_76+X_105+X_40+X_99+X_155>=1;
X_163:=X_76+X_105+X_40+X_99+X_155>=2;
X_164:=X_76+X_105+X_40+X_99+X_155>=3;
X_165:=X_76+X_105+X_40+X_99+X_155>=4;
X_166:=X_76 AND X_105 AND X_40 AND X_99 AND X_155;
X_167:=X_126 AND X_145 AND X_149;
X_168:=长>2 AND CROSS(X_1,长*5);
DRAWICON(X_166 AND X_167,长+44,30);
DRAWICON(X_165 AND X_167,长+38,28);
DRAWICON(X_164 AND X_167,长+32,34);
DRAWICON(X_164 AND X_167,长+32,1);
DRAWICON(X_163 AND X_167,长+26,34);
DRAWICON(X_162 AND X_167,长+20,42);
DRAWICON(X_149,0,25);
DRAWICON(X_145,118,38);
DRAWICON(X_159 AND X_167,X_1,13);
DRAWICON(X_168 AND EXIST(REF(X_168,1),5)=0 AND X_167,X_1+18,23);
X_169:=长=市 AND REF(长<市,1);
X_170:=长<市 AND REF(长=市,1);
X_171:=CROSS(SUM(X_169,BARSLAST(X_170)),0.5);
DRAWICON(X_171,长+6,11);
X_172:=CROSS(SUM(X_170,BARSLAST(X_169)),0.5);
DRAWICON(X_172,长+8,12);
X_173:=CROSS(SUM(X_160,BARSLAST(X_161)),0.5);
DRAWICON(X_173,长+8,13);
DRAWICON(X_161 AND 市=长 AND REF(市=长,1),长+10,14);
X_174:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
X_175:=SMA(X_174,3,1);
X_176:=SMA(X_175,3,1);
X_177:=INTPART(X_175);
X_178:=INTPART(X_176);
X_179:=X_177+X_178;
X_180:=X_179-REF(X_179,1);
X_181:=EMA(WINNER(CLOSE)*70,3);
X_182:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
X_183:=X_182/(X_181+X_182)*100;
X_184:=X_181/(X_181+X_182)*100;
X_185:=EMA(X_183,55);
X_186:=EMA(X_184,55);
一路筹码:IF(X_184<=10,X_184,X_184),NODRAW,COLORYELLOW;
STICKLINE(X_184>REF(X_184,1) AND X_184>20,100+X_184,120,2.5,0),COLORAA00BB;
STICKLINE(X_184>REF(X_184,1) AND X_184>20,100+X_184,120,1.5,0),COLORCC22BB;
STICKLINE(X_184>REF(X_184,1) AND X_184>20,100+X_184,120,0.5,0),COLOREE44BB;
STICKLINE(X_184<=REF(X_184,1) AND X_184>20,100+X_184,120,2.5,0),COLORFF7700;
STICKLINE(X_184<=REF(X_184,1) AND X_184>20,100+X_184,120,1.5,0),COLORFFAA22;
STICKLINE(X_184<=REF(X_184,1) AND X_184>20,100+X_184,120,0.5,0),COLORFFFF55;
STICKLINE(X_184>REF(X_184,1) AND X_184<20,100+X_184,120,2.5,0),COLOR131FFD;
STICKLINE(X_184>REF(X_184,1) AND X_184<20,100+X_184,120,1.5,0),COLOR5050FF;
STICKLINE(X_184>REF(X_184,1) AND X_184<20,100+X_184,120,0.5,0),COLOR7E7EFF;
STICKLINE(X_184<=REF(X_184,1) AND X_184<20,100+X_184,120,2.5,0),COLORAA0000;
STICKLINE(X_184<=REF(X_184,1) AND X_184<20,100+X_184,120,1.5,0),COLORCC0000;
STICKLINE(X_184<=REF(X_184,1) AND X_184<20,100+X_184,120,0.5,0),COLORBLUE;
STICKLINE(X_186>REF(X_186,1),100+X_184,100+X_186,2.5,0),COLOR00AAFF;
STICKLINE(X_186>REF(X_186,1),100+X_184,100+X_186,1.5,0),COLOR00CCFF;
STICKLINE(X_186>REF(X_186,1),100+X_184,100+X_186,0.5,0),COLORYELLOW;
STICKLINE(X_184>X_186 AND X_186>50,100+X_184,100+X_186,2.5,0),COLOR0000AA;
STICKLINE(X_184>X_186 AND X_186>50,100+X_184,100+X_186,1.5,0),COLOR0022CC;
STICKLINE(X_184>X_186 AND X_186>50,100+X_184,100+X_186,0.5,0),COLOR0055FF;
STICKLINE(X_184>X_186 AND X_186<50 AND X_184>50 AND X_186>REF(X_186,1),100+X_184,150,2.5,0),COLOR0000AA;
STICKLINE(X_184>X_186 AND X_186<50 AND X_184>50 AND X_186>REF(X_186,1),100+X_184,150,1.5,0),COLOR0022CC;
STICKLINE(X_184>X_186 AND X_186<50 AND X_184>50 AND X_186>REF(X_186,1),100+X_184,150,0.5,0),COLOR0055FF;
STICKLINE(X_184>80,100+X_184,100+X_184-(X_184-80)/2,2.5,0),COLOR00AA00;
STICKLINE(X_184>80,100+X_184,100+X_184-(X_184-80)/2,1.5,0),COLOR00CC00;
STICKLINE(X_184>80,100+X_184,100+X_184-(X_184-80)/2,0.5,0),COLORGREEN;