擒龙捉妖副图指标公式源码

{公式名称: 擒龙捉妖
公式描述:
无参数
公式类型: 技术指标公式-其他类型
画线方法: 副图
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:无
用法注释:无
公式源码:}
X_1:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_2:=EMA(X_1,9);
X_3:=X_1>X_2;
X_4:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
X_5:=SMA(X_4,3,1);
X_6:=SMA(X_5,3,1);
X_7:=X_5>X_6;
X_8:=REF(CLOSE,1);
X_9:=SMA(MAX(CLOSE-X_8,0),9,1)/SMA(ABS(CLOSE-X_8),9,1)*100;
X_10:=SMA(MAX(CLOSE-X_8,0),26,1)/SMA(ABS(CLOSE-X_8),26,1)*100;
X_11:=X_9>X_10;
X_12:=SMA(X_4,3,1);
X_13:=SMA(X_12,3,1);
X_14:=X_12>X_13;
X_15:=(MA(CLOSE,3)+MA(CLOSE,9)+MA(CLOSE,12)+MA(CLOSE,26))/4;
X_16:=CLOSE>X_15;
X_17:=CLOSE-REF(CLOSE,1);
X_18:=100*EMA(EMA(X_17,9),9)/EMA(EMA(ABS(X_17),9),3);
X_19:=100*EMA(EMA(X_17,26),12)/EMA(EMA(ABS(X_17),26),12);
X_20:=X_18>X_19;
X_21:=X_3 AND X_7 AND X_11 AND X_14 AND X_16 AND X_20;
X_22:=CLOSE-REF(CLOSE,1);
X_23:=IF(CLOSE-REF(CLOSE,1)>=0,X_22,0);
X_24:=REF(CLOSE,1)-CLOSE;
X_25:=IF(CLOSE-REF(CLOSE,1)<=0,X_24,0);
X_26:=SUM(X_23,90)/SUM(X_25,90);
X_27:=100-100/(1+X_26);
X_28:=EMA(X_27,21);
X_29:=EMA(X_28,5);
X_30:=EMA(X_28,3);
X_31:=(CLOSE*2+HIGH+LOW)/4;
X_32:=EMA(X_31,13)-EMA(X_31,21);
X_33:=EMA(X_32,3);
X_34:=EMA(X_32,10);
X_35:=IF(X_33>=X_34,X_33,X_34);
X_36:=IF(X_34-X_33,X_34,X_33);
X_37:=EMA(CLOSE,7)-EMA(CLOSE,21);
X_38:=EMA(0.668*REF(X_37,1)+0.333*X_37,1);
X_39:=IF(X_37>=X_38,X_37,X_38);
X_40:=IF(X_38-X_37,X_38,X_37);
X_41:=X_35>X_36;
X_42:=X_35=X_36;
X_43:=X_39>X_40;
X_44:=X_39=X_40;
X_45:=X_44 AND X_42;
X_46:=X_43 AND X_41;
X_47:=EMA(CLOSE,5);
X_48:=EMA(X_47,0);
X_49:=HHV(MA(HIGH,3),2);
X_50:=LLV(MA(HIGH,3),1);
X_51:=FILTER(X_48>REF(X_48,1) AND X_49<REF(X_49,1) AND CLOSE>REF(CLOSE,1),11);
X_52:=X_51>=1 AND X_21 AND REF(X_50=X_49,1) AND REF(X_41,1);
X_53:=MA(CLOSE,10);
X_54:=MA(CLOSE,54);
X_55:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
X_56:=FILTER(X_55,10);
X_57:=BARSLAST(X_56);
X_58:=REF(HIGH,X_57+2);
X_59:=REF(HIGH,X_57+1);
X_60:=REF(HIGH,X_57);
X_61:=MAX(X_58,X_59);
X_62:=MAX(X_61,X_60);
X_63:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
X_64:=X_57<150;
X_65:=(OPEN-X_62)/X_62*100<30;
X_66:=(CLOSE-LLV(LOW,X_57))/LLV(LOW,X_57)*100<50;
X_67:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
X_68:=VOL/MA(VOL,5)<3.5;
X_69:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
X_70:=X_63 AND X_64 AND X_65 AND X_66 AND X_67 AND X_68 AND X_69;
X_71:=FILTER(X_70,15);
X_72:=(CLOSE-X_54)/X_54<0.1;
X_73:=(CLOSE-X_53)/X_53<0.3;
X_74:=(X_72=1 AND X_73=1)*0.2;
X_75:=(X_74=0 AND REF(X_74,1)=0.2 AND REF(COUNT(X_74=0.2,10)=10,1)=1)*(-0.1);
X_76:=X_75=(-0.1);
X_77:=X_71 OR X_76;
X_78:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
X_79:=CLOSE/REF(CLOSE,1)>1.05 AND CLOSE/OPEN>1.05;
X_80:=VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);
X_81:=MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>REF(MA(CLOSE,10),1) AND MA(CLOSE,5)>REF(MA(CLOSE,5),1);
X_82:=100*(1-WINNER(CLOSE));
X_83:=100-X_82;
X_84:=CROSS(X_83,X_82);
X_85:=X_51>=1 AND X_84;
X_86:=X_84 AND X_21 AND (CLOSE/REF(CLOSE,1)-1)*100>9.97;
X_87:=MA(CLOSE,5);
X_88:=MA(CLOSE,13);
X_89:=MA(CLOSE,34);
X_90:=X_87>REF(X_87,1) AND X_88>REF(X_88,1) AND X_89>REF(X_89,1);
X_91:=EMA(CLOSE,3);
X_92:=EMA(SLOPE(CLOSE,34)*5+CLOSE,21);
X_93:=CROSS(X_91,X_92);
X_94:=X_93 AND REF(X_50=X_49,1) AND X_21 AND REF(X_41,1);
X_95:=CROSS(X_91,X_92) AND X_90;
X_96:=MA(CLOSE,34);
X_97:=X_93>0 OR X_95>0;
X_98:=CLOSE>X_96 AND REF(CLOSE,1)<X_96;
X_99:=CROSS(CLOSE,MA(CLOSE,250)) AND VOL>=REF(VOL,1)*2;
X_100:=(CLOSE/REF(CLOSE,1)-1)*100>9.97 AND CROSS(CLOSE,MA(CLOSE,250));
X_101:=X_99 OR X_100 OR X_98;
X_102:=X_97 AND X_21 AND X_46 AND REF(X_41,1);
X_103:=X_97 AND X_21 AND (CLOSE/REF(CLOSE,1)-1)*100>9.97;
X_104:=X_50=X_49 AND REF(X_49,1)>REF(X_50,1) AND (CLOSE/REF(CLOSE,1)-1)*100>9.97 AND X_97;
X_105:=(3*CLOSE+LOW+OPEN+HIGH)/6;
X_106:=(20*X_105+19*REF(X_105,1)+18*REF(X_105,2)+17*REF(X_105,3)+16*REF(X_105,4)+15*REF(X_105,5)+14*REF(X_105,6)+13*REF(X_105,7)+12*REF(X_105,8)+11*REF(X_105,9)+10*REF(X_105,10)+9*REF(X_105,11)+8*REF(X_105,12)+7*REF(X_105,13)+6*REF(X_105,14)+5*REF(X_105,15)+4*REF(X_105,16)+3*REF(X_105,17)+2*REF(X_105,18)+REF(X_105,20))/210;
X_107:=MA(X_106,6);
X_108:=MA(CLOSE,60);
X_109:=EMA(SMA((CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100,8,1),3);
X_110:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,2);
X_111:=EMA(X_110,12);
X_112:=EMA(X_110,26);
X_113:=100*EMA(EMA(X_17,6),6)/EMA(EMA(ABS(X_17),6),6);
X_114:=100*EMA(EMA(X_17,12),12)/EMA(EMA(ABS(X_17),12),12);
X_115:=100*EMA(EMA(X_17,26),26)/EMA(EMA(ABS(X_17),26),26);
X_116:=CLOSE-REF(CLOSE,1);
X_117:=100*EMA(EMA(X_116,9),9)/EMA(EMA(ABS(X_116),9),9);
X_118:=MA(X_117,5);
X_119:=VOL/CAPITAL*100;
X_120:=MA(X_119,30)/MA(INDEXA,10)*MA(INDEXA,60);
X_121:=MA(X_119,120)/MA(INDEXA,10)*MA(INDEXA,60);
X_122:=1;
X_123:=(HIGH+OPEN+LOW+2*CLOSE)/5;
X_124:=REF(X_123,1);
X_125:=MAX(X_123-X_124,0);
X_126:=ABS(X_123-X_124);
X_127:=SMA(X_125,10,1);
X_128:=SMA(X_126,10,1);
X_129:=COUNT(X_127/X_128<0.2,5);
X_130:=COUNT(LLV(X_123,10)=X_123,10);
X_131:=X_113>REF(X_113,1) AND X_117>REF(X_117,1) AND CROSS(X_110,X_112) AND X_110>REF(X_110,1) AND X_111>REF(X_111,1) AND X_112>REF(X_112,1) AND LOW>X_106 AND LOW>X_108;
X_132:=X_110>X_112 AND CROSS(X_110,X_111) AND CROSS(X_117,X_118);
X_133:=X_129>=1 AND X_130>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND VOL>REF(VOL,1) AND X_113>X_115 AND CROSS(X_110,X_112);
X_134:=X_129>=1 AND X_130>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND VOL>REF(VOL,1) AND CROSS(X_113,X_115) AND X_110>REF(X_110,1);
X_135:=X_129>=1 AND X_130>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND VOL>REF(VOL,1) AND X_110>REF(X_110,1) AND X_113>X_115 AND CROSS(X_114,X_115) AND X_113>REF(X_113,1) AND X_114>REF(X_114,1) AND X_115>REF(X_115,1);
X_136:=X_110>X_112 AND X_117>X_118 AND CROSS(X_113,X_115) AND X_113>REF(X_113,1) AND X_114>REF(X_114,1) AND X_115>REF(X_115,1);
X_137:=X_133 OR X_134 OR X_135 OR X_136;
X_138:=X_137 AND LOW>X_106 AND LOW>X_108;
X_139:=X_110>X_112 AND X_113>X_115 AND CROSS(X_117,X_118) AND X_117>REF(X_117,1) AND X_118>REF(X_118,1) AND LOW>X_106 AND LOW>X_108;
X_140:=X_120<X_122 AND X_121<X_122 AND X_113>X_115 AND X_110>X_111 AND CROSS(X_120,X_121) AND X_106>=X_107;
X_141:=X_129>=1 AND X_130>=1 AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND VOL>REF(VOL,1) AND X_110>X_112 AND X_117>X_118 AND X_106>=X_107;
X_142:=(CLOSE-REF(CLOSE,12))/REF(CLOSE,12)*100;
X_143:=100*VOL/CAPITAL;
X_144:=CROSS(X_142,16) AND X_143>3.5;
X_145:=CLOSE/REF(CLOSE,1)>1.095 AND HIGH=CLOSE;
X_146:=REF(EXIST(X_145,12),1);
X_147:=(REF(HIGH,1)-REF(CLOSE,1))/REF(HIGH,1)>=0.04 AND REF(CLOSE,1)>REF(OPEN,1);
X_148:=X_146 AND X_147 AND CLOSE>REF(HIGH,1) AND LOW>X_106 AND LOW>X_108;
X_149:=X_52 AND X_138;
X_150:=X_84 AND X_97 AND X_131;
X_151:=X_50=X_49 AND REF(X_49,1)>REF(X_50,1);
X_152:=X_151 AND X_139 AND X_144;
X_153:=REF(X_151,1) AND X_144;
X_154:=REF(X_151,1) AND X_144 AND X_138;
X_155:=X_148 AND X_144;
X_156:=REF(X_84,1) AND X_144;
X_157:=REF(X_84,1) AND X_131;
X_158:=EMA(WINNER(CLOSE)*70,5);
X_159:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);
X_160:=FILTER((CROSS(5,X_158) AND X_159<20)*60,10);
DGCM:CROSS(X_158,X_159),COLORMAGENTA;
STICKLINE(DGCM,0,0.6,2,0),COLORMAGENTA;
抓牛:X_52 OR X_102 OR X_94 OR X_85 OR X_86 OR X_104 OR X_149,COLORYELLOW,LINETHICK2;
捉妖:X_77 AND CLOSE/REF(CLOSE,1)>1.095 AND X_80 AND X_79 OR X_103 OR X_150 OR X_152 OR X_153 OR X_156 OR X_155 OR X_154 OR X_157,COLORRED,LINETHICK2;
擒龙:X_97 AND X_84 AND X_101 AND X_81,COLORMAGENTA,LINETHICK2;