通达信《跟庄控盘》升级版指标公式源码

{公式名称: 跟庄控盘升级
公式描述: 跟庄控盘优化升级版
公式类型: 技术指标公式-其他类型
画线方法: 副图
公式源码:}
XA_1:=REF(CLOSE,2)<REF(CLOSE,1)*0.999;
XA_2:=REF(CLOSE,1)<CLOSE*0.998;
XA_3:=EMA(CLOSE,16);
XA_4:=100*(CLOSE-XA_3)/STD(CLOSE,21);
XA_5:=SMA(XA_4,6,1);
XA_6:=XA_5-REF(XA_5,2);
XA_7:=XA_4;
XA_8:=XA_5;
XA_9:=XA_8<(-110);
XA_10:=REF(CLOSE,5)/CLOSE>1.02;
XA_11:=VOL<LLV(VOL,16)*4.5;
XA_12:=EMA(VOL,120)/VOL>1;
XA_13:=LLV(LOW,9);
XA_14:=HHV(HIGH,9);
XA_15:=EMA((CLOSE-XA_13)/(XA_14-XA_13)*100,3);
XA_16:=EMA(XA_15,5);
XA_17:=EMA(XA_16,5);
XA_18:=XA_17<50;
XA_19:=LOW<REF(LOW,3)*1.015;
XA_20:=REF(HIGH,4)/HIGH>1.025;
XA_21:=CLOSE-REF(CLOSE,12);
XA_22:=MA(XA_21,6);
XA_23:=XA_22<(-0.2);
XA_24:=EMA(CLOSE,12)-EMA(CLOSE,26);
XA_25:=EMA(XA_24,9);
XA_26:=(XA_24-XA_25)*2;
XA_27:=XA_24>(-4.5);
XA_28:=MA(CLOSE,20)/HIGH>1.09;
XA_29:=OPEN/CLOSE>1.07;
XA_30:=COUNT(XA_29,4)=0;
XA_31:=OPEN<CLOSE;
XA_32:=COUNT(XA_31,10)>=3;
XA_33:=LLV(LOW,9);
XA_34:=HHV(HIGH,9);
XA_35:=EMA((CLOSE-XA_33)/(XA_34-XA_33)*100,3);
XA_36:=EMA(XA_35,3);
XA_37:=MA(XA_36,3);
XA_38:=XA_36>9;
XA_39:=REF(HIGH,1)<REF(LOW,4)*1;
XA_40:=VOL<=LLV(VOL,9)*1.1;
XA_41:=COUNT(XA_40,10)>=1;
XA_42:=HIGH/CLOSE<1.035 AND OPEN/LOW<=1.035;
XA_43:=HHV(HIGH,15)/LLV(LOW,15)>1.3;
XA_44:=OPEN>=REF(CLOSE,1);
XA_45:=XA_1 AND XA_9 AND XA_9 AND XA_10 AND XA_10 AND XA_18 AND XA_20 AND XA_19 AND XA_27 AND XA_27 AND XA_28 AND XA_30 AND XA_32 AND XA_38 AND XA_39 AND XA_41 AND XA_42 AND XA_43;
XA_46:=REF(CLOSE,2)<REF(CLOSE,1)*1.025;
XA_47:=REF(CLOSE,1)<CLOSE;
XA_48:=EMA(CLOSE,16);
XA_49:=100*(CLOSE-XA_48)/STD(CLOSE,21);
XA_50:=SMA(XA_49,5,1);
XA_51:=XA_50-REF(XA_50,2);
XA_52:=XA_49;
XA_53:=XA_50;
XA_54:=XA_53<(-100);
XA_55:=REF(CLOSE,5)/HIGH>1.025;
XA_56:=VOL<LLV(VOL,16)*2;
XA_57:=EMA(VOL,120)/VOL>1;
XA_58:=LLV(LOW,9);
XA_59:=HHV(HIGH,9);
XA_60:=EMA((CLOSE-XA_58)/(XA_59-XA_58)*100,3);
XA_61:=EMA(XA_60,5);
XA_62:=EMA(XA_61,5);
XA_63:=XA_62<20;
XA_64:=LOW<REF(LOW,3)*1.035;
XA_65:=REF(HIGH,4)/HIGH>1.005;
XA_66:=CLOSE-REF(CLOSE,12);
XA_67:=MA(XA_66,6);
XA_68:=XA_67<(-0.2);
XA_69:=EMA(CLOSE,12)-EMA(CLOSE,26);
XA_70:=EMA(XA_69,9);
XA_71:=(XA_69-XA_70)*2;
XA_72:=XA_69>(-1.6);
XA_73:=MA(CLOSE,50)/HIGH>1.16;
XA_74:=OPEN/CLOSE>1.07;
XA_75:=COUNT(XA_74,4)=0;
XA_76:=OPEN<CLOSE*0.998;
XA_77:=COUNT(XA_76,15)>=1;
XA_78:=LLV(LOW,9);
XA_79:=HHV(HIGH,9);
XA_80:=EMA((CLOSE-XA_78)/(XA_79-XA_78)*100,3);
XA_81:=EMA(XA_80,3);
XA_82:=MA(XA_81,3);
XA_83:=XA_81<20;
XA_84:=REF(HIGH,1)<REF(LOW,5)*0.99;
XA_85:=VOL<=LLV(VOL,9)*1.9;
XA_86:=COUNT(XA_85,20)>=1;
XA_87:=HIGH/CLOSE<1.03 AND OPEN/LOW<=1.03;
XA_88:=REF(VOL,1)>REF(VOL,2)*0.4;
XA_89:=MAX(OPEN,CLOSE)/MIN(OPEN,CLOSE)>1.01 AND MAX(OPEN,CLOSE)/MIN(OPEN,CLOSE)<1.08;
XA_90:=LOW>REF(LOW,1)*0.995;
XA_91:=(HIGH+LOW+CLOSE)/3;
XA_92:=(XA_91-MA(XA_91,14))/(0.013*AVEDEV(XA_91,14));
XA_93:=XA_92<(-50) AND XA_92>(-160);
XA_94:=HHV(HIGH,25)/LLV(LOW,25)>1.09;
XA_95:=XA_46 AND XA_47 AND XA_54 AND XA_55 AND XA_56 AND XA_63 AND XA_64 AND XA_72 AND XA_73 AND XA_75 AND XA_83 AND XA_83 AND XA_84 AND XA_84 AND XA_87 AND XA_88 AND XA_89 AND XA_90 AND XA_93 AND XA_93;
牛转乾坤:XA_95 OR XA_45,COLORYELLOW,LINETHICK2;
A1:IF(牛转乾坤>0,牛转乾坤*1,0),STICK,COLORYELLOW,LINETHICK5;
A2:IF(牛转乾坤>0,牛转乾坤*1,0),STICK,COLORCYAN,LINETHICK5;
A3:IF(牛转乾坤>0,牛转乾坤*0.75,0),STICK,COLORLIRED,LINETHICK5;
A4:IF(牛转乾坤>0,牛转乾坤*0.5,0),STICK,COLORBLUE,LINETHICK5;
A5:IF(牛转乾坤>0,牛转乾坤*0.25,0),STICK,COLORRED,LINETHICK5;
DRAWICON(牛转乾坤,1.15,30);