通达信平台突破主图黄金量柱副图指标公式

通达信平台突破主图指标公式源码:

MA5:MA(CLOSE,5),LINETHICK1,COLORWHITE;
MA10:MA(CLOSE,10),LINETHICK1,COLORYELLOW;
MA20:MA(CLOSE,20),LINETHICK1,COLORFF00FF;
MA60:MA(CLOSE,60),LINETHICK1,DOTLINE,COLORGREEN;
MA120:MA(CLOSE,120),LINETHICK1,DOTLINE,COLORGRAY;
MA240:MA(CLOSE,240),LINETHICK1,DOTLINE,COLORBLUE;
A1:=REF(C,N)=HHV(C,2*N+1); B1:=FILTER(A1,N); C1:=BACKSET(B1,N+1); HD:=FILTER(C1,N);
A2:=REF(C,N)=LLV(C,2*N+1); B2:=FILTER(A2,N); C2:=BACKSET(B2,N+1); LD:=FILTER(C2,N);
UU:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);VV:=UU>REF(UU,1);
前期高位:=REF(C,BARSLAST(HD));
前期低位:=REF(C,BARSLAST(LD));
STICKLINE(H AND YLX=1,前期高位,前期高位,5,0),COLORYELLOW;
STICKLINE(L AND ZCX=1,前期低位,前期低位,5,0),COLORGRAY;
STICKLINE(CROSS(C,REF(前期高位,1)) AND (VOL>=REF(V,1)*2 OR VOL>=REF(V,2)*2),H,L,0,0),COLOR33FFDD;
STICKLINE(CROSS(C,REF(前期高位,1)) AND (VOL>=REF(V,1)*2 OR VOL>=REF(V,2)*2),C,O,3,0),COLOR33CFDD;
STICKLINE(CROSS(C,REF(前期高位,1)) AND (VOL>=REF(V,1)*2 OR VOL>=REF(V,2)*2),C,O,2.5,0),COLOR33DFDD;
STICKLINE(CROSS(C,REF(前期高位,1)) AND (VOL>=REF(V,1)*2 OR VOL>=REF(V,2)*2),C,O,2,0),COLOR33EFDD;
STICKLINE(CROSS(C,REF(前期高位,1)) AND (VOL>=REF(V,1)*2 OR VOL>=REF(V,2)*2),C,O,1,0),COLOR33FFDD;
前高:REF(C,BARSLAST(VV)),COLORWHITE,LINETHICK2;
顶高:REF(C,BARSLAST(VV))*DG,COLORGRAY,LINETHICK2;
PTZQ:=BARSLAST(VV);
PTZF:=(HHV(H,PTZQ)-LLV(L,PTZQ))/LLV(L,PTZQ)*100;
DRAWTEXT_FIX(1,0.01,0.04,0,STRCAT(STRCAT('平台周期 ',CON2STR(PTZQ,0)),' 天')),COLORRED;
DRAWTEXT_FIX(1,0.01,0.08,0,STRCAT(STRCAT('平台振幅 ',CON2STR(PTZF,0)),' %')),COLORYELLOW;

通达信黄金量柱副图指标公式源码:

VOLUME:VOL,VOLSTICK;
倍数:=1.9;
倍量:=VOL>=REF(V,1)*倍数 AND (IF(C<O,C>REF(C,1),1)),COLORYELLOW,NODRAW;
主力启动线:MA(VOLUME,5),COLORRED,LINETHICK2;
主力洗盘线:MA(VOLUME,35),COLORYELLOW,LINETHICK2;
资金异动线:MA(VOLUME,135),COLORBLUE,LINETHICK2;
出击:STICKLINE(CROSS(主力启动线,资金异动线) OR ((主力洗盘线 > 资金异动线) AND CROSS(主力启动线,主力洗盘线)) AND C>O,0,VOL,3,0),COLOR0099FF;
启动:STICKLINE(主力启动线>REF(主力启动线,1) AND (CROSS(VOL,主力启动线) AND (REF(VOL,1)<REF(资金异动线,1) AND REF(VOL,2)<REF(资金异动线,2))) AND C>O,0,VOL,3,0),COLORGREEN;
STICKLINE(倍量,0,VOL,1.5,0),COLORYELLOW;

平台突破

通达信平台突破主图黄金量柱副图指标公式附件中包括平台突破指标参数设置、大智慧版、通达信TNI版、通达信电脑版、手机版等源码文件。