2022金钻预报涨停升级主副图指标和升级初精选等4个选股公式源码

2022预报升级主图指标源码:

DRAWTEXT_FIX(ISLASTBAR,0.5,0,0,HYBLOCK),COLORYELLOW;{在屏幕左上角显示所属行业板块}
DRAWTEXT_FIX(ISLASTBAR,0.55,0,0,DYBLOCK),COLORYELLOW;{在屏幕左上角显示所属地域板块}
DRAWTEXT_FIX(ISLASTBAR,0.6,0,0,GNBLOCK),COLORYELLOW;{在屏幕左上角显示所属概念板块}
DRAWTEXT_FIX(ISLASTBAR,0.5,0.025,0,FGBLOCK),COLORMAGENTA;{在屏幕左上角显示所属风格}
RC1:=REF(C,1);
ZT:=C/REF(C,1)>1.099 AND H>L AND H=C;
CS:=IF(C>=1,10000,100000);
CQS410:=1.10*RC1-49/CS;{考虑到4舍5入}
CQS45 :=1.05*RC1-49/CS;
CQS510:=0.90*RC1+51/CS;
CQS55 :=0.95*RC1+51/CS;
ST:=NAMELIKE('S') OR NAMELIKE('*S');
QS4:= IF(ST, C>=CQS45, C>=CQS410);
QS5:= IF(ST, C<=CQS55, C<=CQS510);
QS6QS4:=IF(ST, H>=CQS45, H>=CQS410);
QS6QS5:=IF(ST, L<=CQS55, L<=CQS510);
STICKLINE(QS6QS4,H,MAX(C,O),0,0),COLORMAGENTA;{QS4后回落}
STICKLINE(QS6QS5,L,MIN(C,O),0,0),COLORLICYAN;{QS5后回升};
STICKLINE(QS4,O,C,1,0),COLORMAGENTA;
STICKLINE(QS5,O,C,1,0),COLORLICYAN;

KK:=C/REF(C,1)>1.099 AND H>L AND H=C;
BMM:=BARSLAST(KK),NODRAW;
VV:=REF(BARSLAST(KK),1),NODRAW;
VMK:=REF(C,BMM),NODRAW;
JHG:=REF(O,BMM),NODRAW;
AZ:(VMK+JHG)/2,NODRAW;
QWSDF:=CROSS(C,AZ) AND C>O AND C>REF(C,1) AND VV>=2 AND VV<=15 AND (C-REF(C,1))/REF(C,1)*100>0 AND (H/L-1)*100>0 NODRAW;
QWSDFA:=FILTER(QWSDF,30);
DRAWTEXT(QWSDFA ,L*0.995,'★预报'),COLORYELLOW;

SS:=QWSDFA=1;
TY:BARSLAST(SS)NODRAW;
TYVMK:=REF(C,TY),NODRAW;
TYJHG:=REF(O,TY),NODRAW;
TYQ:=CROSS(H,TYJHG) AND TY>=5 AND TY<=15;
ER:=FILTER(TYQ,15);
DRAWTEXT(ER ,L*0.995,'加仓'),COLORYELLOW;

TYQ2:=CROSS(H,TYVMK) AND TY>=5 AND TY<=15;
ER2:=FILTER(TYQ2,15);
DRAWTEXT(ER2 ,L*0.995,'加仓2'),COLORMAGENTA;
DRAWICON(ER ,L*0.99,23);
DRAWICON( ER2,L*0.99,23);

MB1:=MA(C,5),COLORYELLOW;
AB:=(H-MB1)/MB1*100;
NHYT:=(H-MB1)/MB1*100>=20 AND H>C;
DRAWTEXT(NHYT,H*1.02,'抛'),COLORGREEN;
TGVFR:=AB>=15 AND AB<20 AND H>C;
A1:=FILTER(TGVFR,12);
DRAWTEXT(A1,H*1.02,'减'),COLORGREEN;

2022预报升级副图指标源码:

RFV:=C/REF(C,1)>1.099 AND H>L AND H=C;
TGH:BARSLAST(RFV),NODRAW;
TYGR:=REF(C,TGH),NODRAW;
UIOP:=REF(O,TGH),NODRAW;
QSCF:=(TYGR+UIOP)/2,NODRAW;
EDCX:=REF(BARSLAST(RFV),1),NODRAW;
QWSDF:=CROSS(C,QSCF) AND C>O AND C>REF(C,1) AND (C-REF(C,1))/REF(C,1)*100>0 AND (H/L-1)*100>0 AND EDCX>=2 AND EDCX<=15 ;
QWSDFA:=FILTER(QWSDF,30),COLORMAGENTA;
STICKLINE(QWSDFA, 0,9, 0.5,1),COLORMAGENTA;
DRAWICON(QWSDFA,8,1);
DRAWICON(QWSDFA,7,1);
DRAWICON(QWSDFA,5,1);
DRAWICON(QWSDFA,6,1);
STICKLINE(QWSDFA, 0,1, 3,1),COLORMAGENTA;
DRAWICON(QWSDFA,1,9);
DRAWICON(QWSDFA,10,18);
DRAWTEXT(QWSDFA ,4,'★预报SJ'),COLORYELLOW;
DRAWTEXT(QWSDFA ,4,''),COLORYELLOW;

CC1:=BARSLAST(QWSDFA);
Q1:=CC1>0 AND CC1<=20 AND RFV;
STICKLINE(Q1, 0,3, 0.3,1),COLORGREEN;
STICKLINE(Q1, 0,0.5, 3,1),COLORGREEN;
DRAWICON(Q1,3.5,9);
DRAWTEXT(Q1 ,1.7,'●板'),COLORMAGENTA;

SS:=QWSDFA=1;
TY:=BARSLAST(SS)NODRAW;
TYTYGR:=REF(C,TY),NODRAW;
TYUIOP:=REF(O,TY),NODRAW;
TYQ:=CROSS(H,TYUIOP) AND TY>=5 AND TY<=15;
ER:=FILTER(TYQ,15);
DRAWTEXT(ER ,8,'加仓'),COLORYELLOW;
TYQ2:=CROSS(H,TYTYGR) AND TY>=5 AND TY<=15;
ER2:=FILTER(TYQ2,15);
DRAWTEXT(ER2 ,8,'加仓2'),COLORMAGENTA;
DRAWICON(ER OR ER2,7.5,1);
DRAWICON(ER OR ER2,5.5,23);
DRAWICON(ER OR ER2,6.5,9);

选股公式包括预报升级初选、精选、加仓选股、加仓2选股请下载附件。