大智慧九全MACD指标公式

INPUT:N(9,1,9);

{基本设定}

{cci-14}

TYP:= (HIGH + LOW + CLOSE)/3;

CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

{rsi-12}

LC:= REF(CLOSE,1);

RSI:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(Abs(CLOSE-LC),12,1)*100;

{RSV-9}

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

{bbi}

BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;

{bias-12}

BIAS:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

{obv}

OBV:=SUM(IF(CLOSE>REF(CLOSE,1),vol,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0);

{参数设定}

VARC:=IF(N=1,CCI,IF(N=2,RSI,IF(N=3,RSV,IF(N=4,BBI,IF(N=5,BIAS,IF(N=6,OBV,IF(N=7,VOL,IF(N=8,AMOUNT,C))))))));

{九全macd}

DIFF:EMA(VARC,12)-EMA(VARC,26);

DEA: EMA(DIFF,9);

MacD: 2*(DIFF-DEA),COLORstICK;

{提示}

IF N=1 THEN BEGIN

DRAWTEXTREL(15,40,'CCI-MACD'),color00FF00;

END;

IF N=2 THEN BEGIN

DRAWTEXTREL(15,40,'RSI-MACD'),color00FF00;

END;

IF N=3 THEN BEGIN

DRAWTEXTREL(15,40,'RSV-MACD'),color00FF00;

END;

IF N=4 THEN BEGIN

DRAWTEXTREL(15,40,'BBI-MACD'),color00FF00;

END;

{www.gUPang.com 指标公式123网_最新股票指标公式}

IF N=5 THEN BEGIN

DRAWTEXTREL(15,40,'BIAS-MACD'),color00FF00;

END;

IF N=6 THEN BEGIN

DRAWTEXTREL(15,40,'能量潮-MACD'),color00FF00;

END;

IF N=7 THEN BEGIN

DRAWTEXTREL(15,40,'成交量-MACD'),color00FF00;

END;

IF N=8 THEN BEGIN

DRAWTEXTREL(15,40,'成交额-MACD'),color00FF00;

END;

IF N=9 THEN BEGIN

DRAWTEXTREL(15,40,'标准-MACD'),color00FF00;

END;