增强版MACD之红箭头选股指标公式

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

X1:=IF (macd<0,BArslAst(crOSS(DIFF,DEA)),0);

绿柱面积:=IF(MacD<0,SUM(MACD,BARSLAST(MACD>0)),0);

前次绿柱面积:=REF(绿柱面积,X1+1);

本次最低绿柱:=IF(MACD<0,LLV(MACD,BARSLAST(MACD>0)),0);

前次最低绿柱:=REF(本次最低绿柱,X1+1);

本次最低价:=LLV(L,BARSLAST(MACD>0));

前次最低价:=REF(本次最低价,X1+1);

Y11:=IF((绿柱面积<0 AND Abs(本次最低绿柱)<ABS(前次最低绿柱) AND 本次最低价<前次最低价 ),1,0);

RS1:=MACD<0 AND REF(MACD,1)<0 AND 本次最低价<前次最低价 AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(MACD)<ABS(REF(MACD,1));

UP3:=RS1 AND UPNDAY(MACD,3);

底柱将背:= IF(UP3,Y11,0);

红箭头:底柱将背;


原文链接:https://www.zhibiaow.com/32554.html,转载请注明出处!感谢您 的配合。