结构背离之结构形成选股指标公式

DIF:=100*(EMA(CLOSE,12)-EMA(CLOSE,26));

DEA:=EMA(DIF,9);

金叉:=crOSS(DIF,DEA);

M1:=BArslAst(金叉);

M2:=REF(BARSLAST(金叉),M1+1);

M3:=REF(BARSLAST(金叉),M2+M1+2);

CH1:=HHV(C,M1+1);

DIFH1:=HHV(DIF,M1+1);

CH2:=REF(CH1,M1+1);

DIFH2:=REF(DIFH1,M1+1);

CH3:=REF(CH2,M1+1);

DIFH3:=REF(DIFH2,M1+1);

pdiFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);

mdiFH2:=INTPART(DIFH2/POW(10,PDIFH2));

PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);

MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));

MDIFT2:=INTPART(DIF/POW(10,PDIFH2));

MDIFT3:=INTPART(DIF/POW(10,PDIFH3));

直接顶背离:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (macd>0 AND REF(MacD,1)>0) AND MDIFT2>=REF(MDIFT2,1);

隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);

TG:=((MDIFT2<REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰顶背离,1));

结构形成:FILTER(TG,20);


原文链接:https://www.zhibiaow.com/32874.html,转载请注明出处!感谢您 的配合。