通达信丑线副图+天赢2号副图金钻指标公式源码+选股预警公式+知根知底副图免费下载

通达信丑线副图+天赢2号副图金钻指标公式源码+选股预警公式

《丑线》副图
*********************************************************************************
VAR1:=REF(LOW,1);
VAR2:=SMA(ABS(LOW-VAR1),3,1)/SMA(MAX(LOW-VAR1,0),3,1)*100;
VAR3:=EMA(IF(CLOSE*1.2,VAR2*10,VAR2/10),3);
VAR4:=LLV(LOW,38);
VAR5:=HHV(VAR3,38);
VAR6:=IF(LLV(LOW,90),1,0);
VAR7:=EMA(IF(LOW<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
VAR8:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR9:=SMA(VAR8,13,8);
主力吸货:VAR7,COLOR0000FF;
吸筹1:STICKLINE(VAR7,0,VAR7,3,0),COLOR0000FF;
吸筹2:STICKLINE(VAR7,0,VAR7,3,0),COLOR6600FF;
吸筹3:STICKLINE(VAR7,0,VAR7,3,0),COLORBB00FF;
吸筹4:STICKLINE(VAR7,0,VAR7,3,0),COLORFF00FF;
吸筹5:STICKLINE(VAR7,0,VAR7,2,0),COLORFF33FF;
吸筹6:STICKLINE(VAR7,0,VAR7,1,0),COLORFF66FF;
吸筹7:STICKLINE(VAR7,0,VAR7,0,0),COLORFF99FF;
吸筹专用线:1.00,COLOR111111;
中线:0.00,COLORBLUE;
MB1:=MA(O,3);
MB2:=MA(C,3);
柱:500*(MB2-MB1),COLORSTICK,COLOR111111;
柱线:柱,COLOR99EEEE;
鉴别线:EMA(柱线,10)*1.3,COLORFF00FF,LINETHICK2;
依托线:EMA(鉴别线,10),COLORGREEN;

《天赢2号》副图
*********************************************************************************
中上线:1.00,COLOR111111;
研析线:=(HHV(HIGH,25)-LLV(LOW,25))/EMA((CLOSE-LLV(LOW,25)),5);
神峰:=研析线,COLORFF00FF,LINETHICK2;
MACC:=EMA(神峰,20)*1.5,COLORGREEN,LINETHICK2;
MACP:=EMA(神峰,89)+2,COLORFFCC00,LINETHICK1;
MACK:=EMA(神峰,10)+2,COLOR0066FF,LINETHICK1;
MACJ:=EMA(神峰,3),COLOR99EEEE,DOTLINE;
柱:(神峰-MACK)*15,COLORSTICK,COLOR111111;
柱线:=柱,COLORWHITE;
中线:0.00,COLORBLUE,LINETHICK2;
STICKLINE(柱线>中线,中线,柱线,1,1),COLORRED;
STICKLINE(柱线<中线,中线,柱线,1,1),COLOR008000;
天赢线:柱,COLOR0066FF,LINETHICK2;
赢底:EMA(天赢线,100),COLORWHITE,DOTLINE;
STICKLINE(天赢线>赢底,赢底,天赢线,0,1),COLORFF00FF;
赢合线:EMA(天赢线,5),COLORFFAA00,DOTLINE;

《丑线线下选股》预警
*********************************************************************************
VAR1:=REF(LOW,1);
VAR2:=SMA(ABS(LOW-VAR1),3,1)/SMA(MAX(LOW-VAR1,0),3,1)*100;
VAR3:=EMA(IF(CLOSE*1.2,VAR2*10,VAR2/10),3);
VAR4:=LLV(LOW,38);
VAR5:=HHV(VAR3,38);
VAR6:=IF(LLV(LOW,90),1,0);
VAR7:=EMA(IF(LOW<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
VAR8:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR9:=SMA(VAR8,13,8);
主力吸货:=VAR7;
吸筹专用线:=1.00;
中线:=0.00,COLORBLUE;
MB1:=MA(O,3);
MB2:=MA(C,3);
柱:=500*(MB2-MB1);
柱线:=柱;
鉴别线:=EMA(柱线,10)*1.3,;
依托线:=EMA(鉴别线,10);
线下选股:鉴别线>中线 AND 依托线>中线 AND 柱线<依托线;

《知根知底》副图
*****************************************************************
中位线:=45.00,COLORBLUE;
日基线:=REF(CLOSE,1),COLORYELLOW,LINETHICK2;
日行线:SMA(MAX(CLOSE-日基线,0),5,1)/SMA(ABS(CLOSE-日基线),5,1)*100,COLORRED,LINETHICK2;
顶线:=HHV(日行线,20),COLOR99EEEE;
上线:=HHV(日行线,20)-25,COLOR99EEEE;
中线:=LLV(日行线,20),COLORFFBB00;
K线:=EMA(日行线,L),COLOR66EEEE;
B线:=REF(上线,1),COLORFF00FF;
知底线:REF(中线,1),COLORFFBB00;
知根线:REF(顶线,1),COLORGREEN;
中迹:(知根线+知底线)/2,COLORWHITE,DOTLINE;