通达信埋伏布林线上主图金钻指标公式源码

以下是指标网收集的通达信埋伏布林上主图金钻指标公式源码

埋伏布林线上主图指标

BOLL:MA(CLOSE,20);
UPPER:(BOLL+2*STD(CLOSE,20));
LOWER:BOLL-2*STD(CLOSE,20);

DD:=UPPER-LOWER;
布林开口:=CROSS(0.5,DD=LLV(DD,30));
DRAWTEXT(布林开口,LOW*0.98,'←布林开口'),COLORYELLOW;
站上上轨:=REF(C<UPPER,1) AND C>UPPER*0.98;
M5:=MA(C,5);
M10:=MA(C,10);
M20:=MA(C,20);
M60:=MA(C,60);
M120:=MA(C,120);
AA:=C>MAX(M5,MAX(M10,MAX(M20,MAX(M60,M120))));
BB:=OBV>=HHV(OBV,60);
埋伏上轨捉妖1:=AA AND BB AND 站上上轨;
埋伏上轨捉妖2:=REF(埋伏上轨捉妖1,1)=0 AND 埋伏上轨捉妖1 ,COLORRED;
DRAWTEXT(埋伏上轨捉妖2,LOW*0.98,'←埋伏捉妖'),COLORCYAN;
VAR1:=CLOSE>REF(CLOSE,1);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
VAR20:=REF(VAR19,1)=0 AND VAR19;
DRAWICON(VAR20=1 AND C>O,L-0.01,1);
DRAWICON(VAR1A=1 ,H*1.0003,2);
DRAWTEXT(VAR20,LOW*0.98,'←买入'),COLORRED;
DRAWTEXT(VAR1A ,HIGH*1.02,'←卖出'),COLORGREEN;

通达信埋伏布林上主图金钻指标公式源码截图:

埋伏布林上主图