通达信《借鸡下蛋》副图+选股预警指标公式源码

通达信《借鸡下蛋》副图指标公式源码:

上线:80.00,COLOR555555,DOTLINE;
中线:50.00,COLOR555555,DOTLINE;
下线:20.00,COLOR555555,DOTLINE;
VAR1:=REF(LOW,1);
VAR2:=SMA(ABS(LOW-VAR1),3,1)/SMA(MAX(LOW-VAR1,0),3,1)*100;
VAR3:=EMA(IF(CLOSE*1.2,VAR2*5,VAR2/10),3);
VAR4:=LLV(LOW,38);
VAR5:=HHV(VAR3,38);
VAR6:=IF(LLV(LOW,90),1,0);
VAR7:=EMA(IF(LOW<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
VAR8:=((C-LLV(L,20))/(HHV(H,20)-LLV(L,20)))*100;
VAR9:=SMA(VAR8,13,8);
吸筹1:STICKLINE(VAR7,0,VAR7,3,0),COLOR0000FF;
吸筹2:STICKLINE(VAR7,0,VAR7,3,0),COLOR6600FF;
吸筹3:STICKLINE(VAR7,0,VAR7,3,0),COLORBB00FF;
吸筹4:STICKLINE(VAR7,0,VAR7,3,0),COLORFF00FF;
吸筹5:STICKLINE(VAR7,0,VAR7,2,0),COLORFF33FF;
吸筹6:STICKLINE(VAR7,0,VAR7,1,0),COLORFF66FF;
吸筹7:STICKLINE(VAR7,0,VAR7,0,0),COLORFF99FF;
吸筹线:VAR7,COLOR0000FF;
吸筹专用线:1.00,COLOR333333;
趋势:CEILING(SMA(VAR9,13,8)),COLORRED,LINETHICK2;
零位线:0.00,COLORBLUE;
反趋势:100*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60)),COLOR007210,LINETHICK2;
STICKLINE(趋势>反趋势,趋势,反趋势,0,1),COLORRED;
MB1:=HHV(反趋势,20);
MB2:=LLV(反趋势,30);
顶线:REF(MB1,1),COLORFF00FF;
MB4:=REF(MB2,1),COLORFFBB00;
MB5:=LLV(趋势,20);
底线:REF(MB5,1),COLORFFBB00;
DRAWICON(CROSS(趋势,吸筹线),吸筹线,17);
DRAWICON(CROSS(顶线,反趋势),反趋势,17);
DRAWICON(CROSS(趋势,底线),底线,17);

通达信《借鸡下蛋》选股预警指标公式源码:

VAR1:=REF(LOW,1);
VAR2:=SMA(ABS(LOW-VAR1),3,1)/SMA(MAX(LOW-VAR1,0),3,1)*100;
VAR3:=EMA(IF(CLOSE*1.2,VAR2*5,VAR2/10),3);
VAR4:=LLV(LOW,38);
VAR5:=HHV(VAR3,38);
VAR6:=IF(LLV(LOW,90),1,0);
VAR7:=EMA(IF(LOW<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
VAR8:=((C-LLV(L,20))/(HHV(H,20)-LLV(L,20)))*100;
VAR9:=SMA(VAR8,13,8);
吸筹线:=VAR7,COLOR0000FF;
趋势:=CEILING(SMA(VAR9,13,8));
反趋势:=100*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60));
MB1:=HHV(反趋势,20);
MB2:=LLV(反趋势,30);
顶线:=REF(MB1,1);
MB4:=REF(MB2,1);
MB5:=LLV(趋势,20);
底线:=REF(MB5,1);
XG:CROSS(顶线,反趋势) AND CROSS(趋势,底线);

借鸡下蛋

借鸡下蛋