通达信动态多空转换主图+乌鸦与麻雀副图+选股公式源码

以下是通达信动态多空转换主图+乌鸦与麻雀副图+选股公式源码:

{公式名称: 动态多空转换
公式描述:
无参数
公式类型: 技术指标公式-其他系
画线方法: 主图叠加
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:无
用法注释:无
公式源码:}
AMB:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORMAGENTA,LINETHICK2;
多空动态线:SAR(5,4,7),COLORYELLOW;
MA2:MA(CLOSE,5),DOTLINE,COLORGREEN;
X_1:=MA(AMB,20);
X_2:=MA(X_1,5);
MACE:EMA(AMB,89),COLORBLUE,LINETHICK2;
MA1:MA(CLOSE,2),DOTLINE,COLOR999999;
DRAWTEXT_FIX(CLOSE>OPEN,0.01,0.9,0,14),COLOR99EEEE;
X_3:=EMA(多空动态线,3);

 

{公式名称: 乌鸦与麻雀
公式描述: 此公式于2022年3月3日失效
无参数
公式类型: 技术指标公式-其他类型
画线方法: 副图
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:无
用法注释:无
公式源码:}
顶:89.5,COLOR555555;
中线:49.5,DOTLINE,COLOR555555;
低位:19.5,COLOR111111;
底线:9.5,COLOR111111;
底边:0,COLORBLUE;
所持股:EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),COLOR8800FF,LINETHICK2;
指数:EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3),COLORFFAA00,LINETHICK2;
X_1:=IF(CROSS(所持股,9),40,0);
X_2:=EMA(CLOSE,3);
X_3:=EMA(CLOSE,21);
X_4:=BARSLAST(CROSS(X_3,X_2))>15;
X_5:=VOL>MA(VOL,5)*2 AND VOL<MA(VOL,5)*5;
X_6:=CROSS(X_2,X_3) AND X_5 AND X_4;
X_7:=IF(X_6,40,0);
X_8:=DRAWTEXT(X_6,30,2);
MAC1:EMA(所持股,3),DOTLINE,COLORCCCCCC;
MAC2:EMA(指数,3),DOTLINE,COLORGREEN;
X_9:=EMA(所持股,20);
X_10:=EMA(指数,20);

 

{公式名称: 乌鸦与麻雀
公式描述: 此公式于2022年3月3日失效
无参数
公式类型: 技术指标公式-其他类型
画线方法: 副图
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:无
用法注释:无
公式源码:}
顶:89.5,COLOR555555;
中线:49.5,DOTLINE,COLOR555555;
低位:19.5,COLOR111111;
底线:9.5,COLOR111111;
底边:0,COLORBLUE;
所持股:EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),COLOR8800FF,LINETHICK2;
指数:EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3),COLORFFAA00,LINETHICK2;
X_1:=IF(CROSS(所持股,9),40,0);
X_2:=EMA(CLOSE,3);
X_3:=EMA(CLOSE,21);
X_4:=BARSLAST(CROSS(X_3,X_2))>15;
X_5:=VOL>MA(VOL,5)*2 AND VOL<MA(VOL,5)*5;
X_6:=CROSS(X_2,X_3) AND X_5 AND X_4;
X_7:=IF(X_6,40,0);
X_8:=DRAWTEXT(X_6,30,2);
MAC1:EMA(所持股,3),DOTLINE,COLORCCCCCC;
MAC2:EMA(指数,3),DOTLINE,COLORGREEN;
X_9:=EMA(所持股,20);
X_10:=EMA(指数,20);