通达信百家乐副图+选股指标公式源码

通达信百家乐副图指标公式源码:

{公式名称: 百家乐
公式描述:
无参数
公式类型: 技术指标公式-大势型
画线方法: 副图
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:无
用法注释:无
公式源码:}
指标123网:0,COLORGRAY,NODRAW;{ WWW.ZHIBIAO123.CN};
X_1:=IF(HHV(ABS(HHV(CLOSE,6)/LLV(CLOSE,6)-1),6)>10/100,3,6);
X_2:=IF(MINUTE=5,X_1*48,IF(MINUTE=15,X_1*16,IF(MINUTE=30,X_1*8,IF(MINUTE=60,X_1*4,X_1))));
X_3:=VOL<MA(VOL,5) AND MA(VOL,5)<MA(VOL,55);
X_4:=CLOSE/REF(CLOSE,1)>1.0138;
X_5:=MA(CLOSE,10)>CLOSE*1.05;
X_6:=MA(CLOSE,10)<CLOSE*1.1;{ WWW.ZHIBIAO123.CN}
X_7:=MA(CLOSE,60)>CLOSE*1.28;
X_8:=X_3 AND X_4 AND X_5 AND X_6 AND X_7;
X_9:=X_2 AND X_8;{ WWW.ZHIBIAO123.CN}
X_10:=(CLOSE-MA(CLOSE,2))/MA(CLOSE,2)*100;
X_11:=INDEXC;
X_12:=MA(X_11,13);
X_13:=X_12>1.05*X_11;
X_14:=(CLOSE-REF(CLOSE,26))/REF(CLOSE,26)*10;
X_15:=X_13;{ WWW.ZHIBIAO123.CN}
X_16:=X_14<(-2.3);
X_17:=X_10<(-2.7);
X_18:=X_15 AND X_16 AND X_17;
X_19:=CROSS(0.5,X_18);
X_20:=CROSS(X_19,0.5);
X_21:=BARSLAST(X_20=1);
X_22:=X_21<=5 AND CLOSE<REF(CLOSE,X_21);
X_23:=X_19 OR X_22;{ WWW.ZHIBIAO123.CN}
X_24:=CLOSE/MA(CLOSE,20)*100<80;
X_25:=CLOSE/MA(CLOSE,40)*100<78;
X_26:=CLOSE/MA(CLOSE,60)*100<72;
X_27:=HIGH>LOW*1.051;
X_28:=X_27 AND COUNT(X_27,5)>1;
X_29:=X_23 AND X_28 AND (X_24 OR X_25 OR X_26);

隐藏内容

此处内容需要权限查看

  • 普通20金币
  • 会员12金币6折
  • 永久会员免费推荐

X_34:=(CLOSE-MA(CLOSE,60))/MA(CLOSE,60)*100<(-23)*X_31 AND X_33<23 AND COUNT((CLOSE-MA(CLOSE,60))/MA(CLOSE,60)*100<(-20),2)=1 AND (OPEN>CLOSE OR OPEN<CLOSE) AND OPEN/REF(CLOSE,1)>0.96;
X_35:=X_32 OR X_34;{ WWW.ZHIBIAO123.CN}
X_36:=IF(DATETODAY(DATE)<11700,1,DRAWNULL);
X_37:=IF(X_35=1,1,0)*X_36;
X_38:=CLOSE/MA(CLOSE,40)*100<78;
X_39:=CLOSE/MA(CLOSE,60)*100<74;
X_40:=HIGH>LOW*1.051;{ WWW.ZHIBIAO123.CN}
X_41:=X_40 AND COUNT(X_40,5)>1;
X_42:=(HIGH+LOW+CLOSE)/3;{ WWW.ZHIBIAO123.CN}
X_43:=(X_42-MA(X_42,14))/(0.015*AVEDEV(X_42,14));
X_44:=X_41 AND (X_38 OR X_39) AND MA(CLOSE,27)/CLOSE>1.169 AND MA(CLOSE,17)/CLOSE>1.158 AND CLOSE<MA(CLOSE,120) AND MA(CLOSE,60)<MA(CLOSE,120) AND MA(CLOSE,60)>MA(CLOSE,30) AND X_43>(-210);
X_45:=CLOSE/REF(LLV(LOW,10),1)<0.96 AND CLOSE!=LOW AND CLOSE<OPEN;
X_46:=CLOSE<DMA(EMA(CLOSE,21),SUM(VOL,8)/5/CAPITAL)*0.76 AND CLOSE<REF(HIGH,13)*0.775 AND VMACD.MACD(13,63,10)>0 AND (MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW))+ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100))/(AMOUNT/VOL/100)*50>2.1 AND REF(LOW,1)/HIGH<1.02 AND VOL<REF(VOL,1)*3 AND KDJ.J(28,14,7)<10 AND MA(VOL,10)<MA(VOL,50)*1.7;
X_47:=(CLOSE-MA(CLOSE,2))/MA(CLOSE,2)*100;
X_48:=INDEXC;{ WWW.ZHIBIAO123.CN}
X_49:=MA(X_48,13);
X_50:=X_49>1.05*X_48;
X_51:=(CLOSE-REF(CLOSE,26))/REF(CLOSE,26)*10;
X_52:=X_50;{ WWW.ZHIBIAO123.CN}
X_53:=X_51<(-2.3);
X_54:=X_47<(-2.7);
X_55:=X_52 AND X_53 AND X_54;
X_56:=CROSS(0.5,X_55);
X_57:=CROSS(X_56,0.5);
X_58:=BARSLAST(X_57=1);
X_59:=X_58<=5 AND CLOSE<REF(CLOSE,X_58);
X_60:=X_56 OR X_59;{ WWW.ZHIBIAO123.CN}
X_61:=CLOSE/MA(CLOSE,20)*100<80;
X_62:=CLOSE/MA(CLOSE,40)*100<78;
X_63:=CLOSE/MA(CLOSE,60)*100<72;
X_64:=HIGH>LOW*1.051;{ WWW.ZHIBIAO123.CN}
X_65:=X_64 AND COUNT(X_64,5)>1;
X_66:=X_60 AND X_65 AND (X_61 OR X_62 OR X_63);
百家乐:X_9+X_29+X_30+X_37+X_44+X_46+X_66>=3 AND X_45,COLORYELLOW;

通达信百家乐指标公式案例截图:

百家乐